SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
Yeah, I've been googling heavily this past 2 days trying to find someone who facing the same problem as me, but found none. Hopefully someone here can shed a light in my situation.<p>My transmission is behaving weirdly, and by weirdly I mean sometimes it feels broken, sometimes (most of the time) it's completely fine. <p>Here's the story, about 2 months ago I was driving normally (35-40mph) when sudddenly the transmission went to limp mode. This was out of the blue, there's no rain, i didnt do sprints, just coasting on the highway and then suddenly i notice the box didnt shift down and the arrow was flashing. I pulled over to a stop, pop up the hood pretending to know what I'm doing and check the auto tranny oil (which I just replaced 200miles earlier). Everything smelled fine, no burnt smell and the oil is still bright red. <p>Fearing the worst and deciding that there's nothing I can do about it, I walk away to grab a bite. After about 40 minutes, came back, start the engine and noticed the arrow is still flashing I decided I'm just gonna nurse it home. <p>Surprise... the damn thing shift's properly, it engages the gears properly... it's like nothing happened! And after driving for 5 minutes, suddenly the arrow stop flashing. And I was happier than a mofo.<p>And then fast forward to today... <p>6000 miles later (of which consisted of a 2000 miles non stop road trip), due for another service it began acting up again. This time it's in the heavy rain, I tried to accelerate from 40 and noticed, briefly, the steering was pulling to the left sharply (like a bad torque steer). And when I brake to a stop; the car wanders a bit like the brakes were locking up. Yes, my abs was broken but no i didnt slammed on the brakes, i brake just like a normal driver would. I think this is due to the box not downshifting. <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <p>But I just shrugged it off drove off normally after that. Suddenly, I noticed that the engine was revving up but it's moving very sluggishly. At that moment i think the car was stuck in 4th (but there was no flashing arrow!) I did a stop go and the car was pulling away normally, i feel the 1st gear, 2nd gear and then a delay.... and the car was revving up but it's moving away slowly. Wow, a missing 3rd gear. <p>So I thinking I'm screwed if the car went to limp mode since i think limp mode is 3rd gear. I stopped the car, switched off the engine and then start it back up again... <p>NOW the fun starts, "There it is, a flashing arrow. I'm frakked!" But surprise, the car is moving but stuck in limp mode.. in 3rd! This is new, 5 minutes ago it didn't want the 3rd, but now all it want is the 3rd? Sheesh, this stupid car is worse than my girlfriend! <p>I keep driving and went to parked my car. Put it in reverse and Damn! It's struggling to find reverse, the damn thing just wont engage. I have to restart the engine twice to do a normal reverse parking as each restart it seems the box can find the reverse.<p>After a while (about 3 hours) I went back to the car and start it again, the arrow is still flashing but the tranny works fine. It finds every gear and behaves normally. I switched off the engine again, went to the toilet and after 10 minutes, there's no arrow and the box is completely okay like nothing happened. What the frakk <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0"><p>After doing minor research, I narrow it down to either the solenoid or the TCU as I think the problems seems to be electrical or electrical related. What do you guys think? Is it the solenoid, TCU or is time to get a new/used/another tranny?<p>Sorry to bore you guys with my story, thanks for the patience to read my long ass post.
 

·
Registered
Joined
·
16,971 Posts
I would say Soleniod .... but auto trannys are my weakest points on volvos. <p>I just pull them out and put manuals in lol
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
Re: (Chilled Man)

Dude, trust me if I could find a manual tranny (even if the guy wanted $3000 for it) I get one in a heart beat.<p>Anyway, I'm officially screwed. It's throwing AT 223, AT 323 and AT 324. Which basically means my 3rd and 4th is fried. I'm thinking of ordering a transmission rebuild kit. Anybody know who made the best one and where could I get one online?<p>*sigh* Meanwhile, looks like I'll be riding to work starting next month. And to make matter worse, I'm in a middle of a freak monsoon season which means I'll be stuck under flyovers most of the time. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/mad.gif" BORDER="0">
 

·
Registered
Joined
·
16,971 Posts
Jordan VW has three manual tranny swaps for sale right now ... <p>Less then 1k for each one the cheapest is at 600ish just need to buy fly wheel and throwout bearing
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #5 ·
Yeah that sounds nice, but how much would it cost to have it air-freight to malaysia? That is if he's willing to air freight it. I emailed lot's of online seller who got manual tranny but none of 'em are willing to ship it here.
 

·
Registered
Joined
·
16,971 Posts
oh........ <p>Ask him hes on VS
 
1 - 6 of 6 Posts
Top