SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello Guys,<p>great little forum here, i was wondering whether anyone could shed some light on my situation.<p><br>Basically i have an XC90 T6 executive, 2004 model and a couple of months ago The RTI stopped working, could not read disk error etc.<p>SO i took the unit apart cleaned the lens with some cd lens cleaning kit soultion on a cotton bud yet the problem still persists.<p>I Even took the car to a friend who had the cleaning disk with no avail and the problem still persisted.<p>So anyway i came across another DVD NAV UNIT from a later 54 plate XC90 and plugged that into my 04 plate car and it worked hurrah hey presto. Well it did the first time i plugged it in.<p>Now the unit starts up the screen goes up, sometimes it gets right to the map other times it gets as far as loading, and then every time the screen folds away. Usually after about 10 seconds. Then i cant bring the screen back up no matter what i do or press.<p>HMMMM..... utter confusion, i'm now wondering whether the cars are coded to each individual dvd unit, and if so can this restriction be removed in any way.<p>I'll post back shortly with any error codes from the hidden screen menu. If there are any.<p>regards<br>and hope you can help<p>dips<p>I'm now thinking the best solution would be to remove the whole laser unit from my old driver and replace it with the new one? any suggestions as to whether this would work?
 

·
Registered
Joined
·
199 Posts
I think you may be right with the coding of each unit to the cars software. Replacing almost any major electrical part needs it reset at the dealer.<br>A p.i.t.a. (pain in the @ss) thats supposed to reduce the possibility of theft for chopping cars, but its mostly a money maker for the dealers.<br>Time to connect to the mothership. <br><BR><BR>
<i>Modified by cdnx90 at 7:00 AM 8-3-2009</i>
 
1 - 2 of 2 Posts
Top