SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
728 Posts
Discussion Starter · #1 ·
I've posted here as I think there's more folks familiar with tuning a 2.5T than in the Mk1 XC90 forum...

I've been struggling to get any assistance from Gustav - I accept he's busy and likely has other priorities so trying to see if there's anything else I can try in the meantime. I last had communication with him in September of 2020.

Vehicle is a 2006 XC90 2.5T with Snabb fresh air pipe and downpipe, stock airbox with free flow filter, and Forge CBV. TCV was replaced with OEM during tuning process. Vacuum lines all recently replaced with silicone.

In the latest revisions of his Stage 2 tune for me, I was starting to trigger a limp mode due to ECM-601C signal too high. I basically lived with it by staying off full boost and I could drive around it for the most part so it wasn't particularly problematic. Normal peak boost with tune was around 16-17 psi. I would see it climb sometimes to 19-20 and then possibly surge a bit then cut out. But last year, we got a travel trailer and I rely upon the extra power to help with the towing. I've had to keep the Torque app handy so my wife can clear the ECU faults while on the road in order to restore boost. Going in to limp mode with trailer on a hill is no fun.

I provided Gustav with logs and he indicated he knew what the problem might be but I never got another map. I thought issue might have been fixed after the CBV install as some of the vacuum hoses were replaced at that time, one at least had crack, and it was good on the drive home from the shop but the problem continued to reoccur after that.

Lately, it seemed to be even easier to get it to happen so I wasn't sure what could be making it more sensitive. The line to the boost gauge popped off recently so I replaced that line and added fresh clamps.

I was reading another thread here that suggested going back to stock, so I did that this weekend. Power was back to stock and I was seeing upwards of 9psi under load. There were no surges or fluctuations in boost. Does that rule out mechanical issues and I just need to wait on Gustav?

Automotive tire Motor vehicle Electrical wiring Gas Rim

Automotive fuel system Hood Automotive tire Motor vehicle Automotive design


Terrible pic.

Car Motor vehicle Steering part White Automotive design
 

·
Registered
Joined
·
728 Posts
Discussion Starter · #2 ·
Happy to report I was able to reconnect with Gustav today, got a new map and did a few pulls for him.
 
  • Like
Reactions: CKAVolvo

·
Registered
Joined
·
728 Posts
Discussion Starter · #3 ·
New map functioned fine over 200kms of towing on relatively flat terrain. Tried to get it to overboost but it wouldn't. So far so good.
 
1 - 3 of 3 Posts
Top