SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello
I am writing this post because I need your help. I am the owner of the Volvo XC60 R-design from 2019, D4 + Polestar engine. Regularly every few months on the electronic gauge, I have information about its excess. I drive 2x31 miles a day by car. This message appears and disappears. Once I have excess oil, and the second time I start it, the level is ok. On Tuesday I have the 5th visit to the service with this problem. Before the last visit, I went to an independent service, they connected my car to VIDA Online and it turned out that the oil level is 3/4 of the level, so it's ok, while the electronic gauge showed excess. I don't know what to do with it. My warranty expires in half a year and I am afraid that I will be left alone with this problem.
 

·
Registered
Joined
·
32 Posts
Mine does the same sometimes. The manual says the car should be stationary on flat ground with the engine turned off For at least 5 minutes to get an accurate reading. I tried this and now it’s showing the right amount of oil.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hello Guys,
Today I was in Volvo service. After two hours, I picked up the car. The service said that the oil level was ok. They uploaded new software, calibrated the sensor again and that's it. I came home. In the evening I start the car and I see the following message on the display:


I drove about 10 miles. I parked the car. I went shopping. I came back fifteen minutes later and I see something like this:


I do not know what's wrong. I wrote an official email to Volvo. I'm waiting for a response. Has anyone had similar problems?
 
1 - 3 of 3 Posts
Top