SwedeSpeed - Volvo Performance Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
498 Posts
Discussion Starter · #1 ·
So my 2015 xc60-R had developed a clunk/creak about 4-5 months ago and recently got worse. It happens when i'm braking going into a turn and it is sometimes severe enough to feel in the steering wheel. I've brought it to the dealership 3 times so far over the past month and they've replaced the following: front chassis reinforcement tabs, sway bar bushings and connecting rods, and upper strut mount bearings along with strut re greasing. While the clunk/creak is not nearly as bad as it once was, it is still there. Anyone else experiencing this issue and if so, what fixed your car?
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #2 ·
I dropped the car off this past tuesday and it's still at the dealership. The dealer ordered replacement struts, but now VNCA does not want them to install them as they don't think that they would cause the issue. As of right now the dealership is going back and forth with VCNA about possible repairs. I also opened a case with VCNA this past tuesday and asked to be traded out of my car, so we'll see how that goes. Does anyone have experience with VCNA trading you out of your car or maybe a buyback? I think my car is getting close to qualifying as a lemon.
 

·
Registered
Joined
·
55 Posts
I have the same problem on my '13 RD. Started to notice it about 1-2 months ag0- making a creeking poping noise when slowing down and enterering either a right of left turn at lowr speed.
With regards to the lemon issue-you will need to file a claim with your state first I belive.
 

·
Registered
Joined
·
312 Posts
I have the same issue in my 15 as well. It started out about a month or so ago. Very faint at first and could barely hear it. At first I thought it was some rocks stuck in tires since it only did it in slow turns during parking but over a month now it got louder for others to notice. I tried going under the car to check it out but can't seem to pin point the issue.
I would imagine it would have to be one of the ball joints. I checked to see if all the bolts were tightened but didn't find any.
If anyone figures out definitely post up. I don't feel like going to dealer multiple times to diagnose the issue as they never have loaner cars and it's about 45 min away from me.
 

·
Registered
Joined
·
41 Posts
I JUST took my 15.5 XC60 w/ 30k on it in for the same issue!! The tech at dealership told me that the brake pads are not "lubed/ greased" at all when the cars come from factory....anyways they did that to the front pads and the sound seems to have gone away!! Hope this helps


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #10 ·
Got the car back, haven't driven it enough to confirm if the clunk is gone, but from my short drive home i did not hear it. They replaced the left lower control arm. They also caused some body damage when they were poking around for the noise (they had told me they had to remove the bumper, i also noticed two new fender liners on the bill). Looks like i will be needing two new side sills, that smaller sill peice behind the drive side wheel, and a refinish on my front bumper...
 

·
Registered
Joined
·
837 Posts
I JUST took my 15.5 XC60 w/ 30k on it in for the same issue!! The tech at dealership told me that the brake pads are not "lubed/ greased" at all when the cars come from factory....anyways they did that to the front pads and the sound seems to have gone away!! Hope this helps


Sent from my iPhone using Tapatalk
Yep, same thing and fix for us per my post above. When the service rep called and told me this was the fix I thought "no way"...that was about 2 months ago. The clunk hasn't returned. I noticed the grease on the backs of the pads when I replaced the front struts early last month.
 
1 - 11 of 11 Posts
Top