SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Last week I experienced sudden loss of power. I figured it was a fuel issue. The first easy check I disconnected the fuel line from carb and turned over engine... It's primitive and messy but it did verify fuel pump was working fine and plenty of fuel to carbs... Next I popped open the bowls on each carb. One was full of fuel the other bone dry. I found some crud obstructing the the inlet cleaned it and put it back together. Both bowls now fill no problem, but now it won't start. Turns over just fine but won't start. I don't really want tear much deeper into carbs and before it at least started even though there was no top end. Any ideas? It's a 1969 p1800 dual carb.

Sent from my moto e5 (XT1920DL) using Tapatalk
 

·
Registered
Joined
·
480 Posts
So what happens if you spray a little starting fluid into the carbs?

Sometimes Fuel problems are really ignition problems and vice versa. Perhaps an ignition problem was manifested during the carb and fuel pump evolutions.

The SU carbs are well documented and following along on the various tuning and setup documentation usually results in a car that at least runs and develops decent power. Even on my 142 with twin SU HIF6's the rear carb shaft seals are leaking, but I currently have that carb tuned to run best in the 40-50 MPH mid power range
 

·
Registered
Joined
·
2,569 Posts
I agree with Scaramoucheii. Check the ignition first to make sure that you don't have a coincidence factor. No point chasing a non existent fuel issue if the ignition is the problems - and ignition is usually less messy to deal with. That said, if crud was obstructing the needle valve on one carb I have to wonder whether something got sucked up into the metering circuits / jets on that carb. However, if one carb became non operational, you would typically be able to get some activity on the remaining carb and 2 cylinders. If you are not getting any indication of firing on the presumably good carb and you have ruled out ignition problems, you may have debris in both carbs metering circuits.

The obstruction in the needle valve leaves me wondering where the obstruction came from. Are you running a fuel filter? Are pieces coming out of a failing fuel pump? The definitive test for the fuel pump would be to find a fuel pressure gauge for carbs (low pressure) and test the delivery pressure during cranking.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I put all back together and let it sit a couple of days. She fired right up and ran a little dogged for a minute then smoothed out and ran fine no power issues.

But I do need to put a fuel filter on, probably something inline just before the pump. As far as the ignition stuff goes I probably ought to at least change my spark plugs, I am thinking I may change my cool and condenser too just to be safe.

Sent from my moto e5 (XT1920DL) using Tapatalk
 

·
Registered
Joined
·
2,569 Posts
But I do need to put a fuel filter on, probably something inline just before the pump.
I departed from the world of carbs and mechanical fuel pumps several decades ago; but, I think the fuel filter should go on the pump discharge not the suction side. Mechanical pumps (pumps in general) don't generate a lot of negative pressure on the suction side so anything that impedes flow on the suction side can create problems.

I also seem to recall that the original Volvo mechanical fuel pumps have an internal filter / large lump strainer that may be user serviceable. You might want to check into that. Perhaps it disintegrated and that was what was blocking the needle valve?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I departed from the world of carbs and mechanical fuel pumps several decades ago; but, I think the fuel filter should go on the pump discharge not the suction side. Mechanical pumps (pumps in general) don't generate a lot of negative pressure on the suction side so anything that impedes flow on the suction side can create problems.

I also seem to recall that the original Volvo mechanical fuel pumps have an internal filter / large lump strainer that may be user serviceable. You might want to check into that. Perhaps it disintegrated and that was what was blocking the needle valve?
Thanks for the info I will double check fuel pump.

Sent from my moto e5 (XT1920DL) using Tapatalk
 

·
Registered
Joined
·
480 Posts
Agreed with 142 Guy, Filter goes on pressure side of Fuel Pump or else you will have issues when it become dirty.

Note that Diaphragm pumps are quite tolerant of small particles,

Another question, does your tank have an Internal Sock Filter? Being a '69 may not as I think that may have only come along with the E cars, but if the tank was replaced at some point, or your car is a end of '69 production it may have the tank with a large Bronze plug in the bottom that allows you to change the "pre filter" sock on the end of the pickup tube inside the tank. If it does you should check it because if it is Old/Clogged/Deteriorated may also be a factor in your current situation.
 
1 - 8 of 8 Posts
Top