SwedeSpeed - Volvo Performance Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
2,141 Posts
Discussion Starter · #1 · (Edited)
So, my flipping windshield washer motor isn't working. The fuse hasn't popped, so either the retards at the dealer screwed another thing up on my car or it is just dead. I am getting frustrated with this car. Anyone with VIDA please help.

Sent from my HTC Sensation 4G using Tapatalk 2
 

·
Registered
Joined
·
1,341 Posts
So, my flipping windshield washer motor isn't working. The fuse hasn't popped, so either the retards at the dealer screwed another thing up on my car or it is just dead. I am getting frustrated with this car. Anyone with VIDA please help.

Sent from my HTC Sensation 4G using Tapatalk 2
I believe the pump is either inside or on the bottom of the reservoir. Mine died and had my indie replace it I don't think it was too expensive of a job IIRC.
 

·
Registered
2005 V70R, Midnight Blue, M66
Joined
·
2,124 Posts
Pump is located in a cutout on the side of the resevoir.
It requires moving the front bumper cover and from there a very easy replacement. Cost is about $35 as Irecall and it is a FoMoCo part if you can cross reference for a cheaper price.
 

·
Registered
Joined
·
2,137 Posts


It's number 6 & 8 in the picture. There's three different ones depending on your chassis number.

Low Pressure (#6)
Part # 9169611
CH -325023

Low Pressure (#6)
Part # 30699953
CH 325024-424999

High Pressure (#8)
Part # 30699674
CH 425000-

Hope this helps!
 

·
Registered
Joined
·
2,141 Posts
Discussion Starter · #5 ·
Thanks guys. So, do I need two pumps? Neither the windshield or headlight squirters are working. Also, should I replace the wiper washer motor seal while I am at it?

Sent from my HTC Sensation 4G using Tapatalk 2
 

·
Registered
Joined
·
1,028 Posts


May as well replace the seal; its just an o-ring probably 25 cents?
Both windshield and headlight washers come from this one reservoir.

Suggest pulling your bumper cover to first see WHY its not working. Maybe a hose popped off like it did on mine. But in that case, you'd have an out-of-fluid warning. Used zip-tie as a clamp then refilled, all was good.
 

·
Registered
Joined
·
3,758 Posts
My windshield wiper spray haven't worked in almost 6 months :D I guess I will look into checking the motor also.
 

·
Registered
Joined
·
2,141 Posts
Discussion Starter · #8 ·


May as well replace the seal; its just an o-ring probably 25 cents?
Both windshield and headlight washers come from this one reservoir.

Suggest pulling your bumper cover to first see WHY its not working. Maybe a hose popped off like it did on mine. But in that case, you'd have an out-of-fluid warning. Used zip-tie as a clamp then refilled, all was good.
Thanks for the pic it's super helpful. I don't have a low fluid warning and have felt around the reservoir not finding any leaks either. Was hopping that it somehow came unplugged, but it doesn't seem like it. Like I said above the fuse hasn't popped, so I think I have covered my bases and the motor is just dead. Got a low batter warning, but don't think it is that causing the issue.

Sent from my HTC Sensation 4G using Tapatalk 2
 

·
Registered
Joined
·
2,137 Posts
Thanks guys. So, do I need two pumps? Neither the windshield or headlight squirters are working. Also, should I replace the wiper washer motor seal while I am at it?

Sent from my HTC Sensation 4G using Tapatalk 2
The low pressure motors are for the headlamps and windshield. You should only need one.
 

·
Registered
Joined
·
1,028 Posts
Thanks for the pic it's super helpful. I don't have a low fluid warning and have felt around the reservoir not finding any leaks either. Was hopping that it somehow came unplugged, but it doesn't seem like it. Like I said above the fuse hasn't popped, so I think I have covered my bases and the motor is just dead. Got a low batter warning, but don't think it is that causing the issue.

Sent from my HTC Sensation 4G using Tapatalk 2
You may have nailed it. This car is finicky about battery power, starts shutting down systems it considers non-vital. But you said yours has been non-working for 6 months, while I doubt you've had low battery that long.
 

·
Registered
Joined
·
2,141 Posts
Discussion Starter · #11 ·
You may have nailed it. This car is finicky about battery power, starts shutting down systems it considers non-vital. But you said yours has been non-working for 6 months, while I doubt you've had low battery that long.
Mine just recently acted up. Ion is the one with the 6 month issue. My fuel pressure is getting wonky from time to time, so maybe I will try the battery first. I think I am going to get an Interstate Battery since they get the best ratings.

Sent from my HTC Sensation 4G using Tapatalk 2
 

·
Registered
2005 V70R, Midnight Blue, M66
Joined
·
2,124 Posts
You do need to confirm your pump configuration.
My 2005, V70R, uses a single pump but reverses battery polarity at the pump to select front or rear wiper. Others use two different pumps.
 

·
Registered
Joined
·
2,141 Posts
Discussion Starter · #13 ·
You do need to confirm your pump configuration.
My 2005, V70R, uses a single pump but reverses battery polarity at the pump to select front or rear wiper. Others use two different pumps.
Forgot to mention I have a SR, so I probably only need one pump. Gonna try the battery first.

Sent from my HTC Sensation 4G using Tapatalk 2
 

·
Registered
Joined
·
3,758 Posts
Anyone know which fuse is the washer pump? I should check that before I order the pump.
 

·
Registered
Joined
·
20 Posts
Anyone know how many and which pressure the R takes? Hoping only one and that it's low pressure since I made a rookie mistake and already bought one. Also do I really have to take off the front bumper?? Not really looking forward to that.
 
1 - 15 of 15 Posts
Top