SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
528 Posts
Discussion Starter · #1 ·
Not sure what this one is or does, but its broken (wires fell out of it) and probably throwing my chassis code. Looking for a replacement so it can keep doing whatever it is that it does...



 

·
Registered
Joined
·
6,571 Posts
Accelerometer. Volvo PN 30782311 if it's the right side (I assume right side = driver side...) . PN 30782312 for the left side.
 

·
Registered
Joined
·
1,080 Posts
I have a spare passenger side unit but unless this photo is flipped, it looks like you actually need the driver side.
 

·
Registered
Joined
·
1,080 Posts
PM me if you would like to buy my spare passenger side unit. It was only on my car(only driven in CA) for a few months and it won't cost you anywhere near the $200+ that dealers/vendors are asking.
 

·
Registered
Joined
·
2,045 Posts
I got one off a parts car from someone for $50 a few months back as mine was shorting out and throwing the chassis code. Scanned with vida to find issue.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
8,055 Posts
I feel like a lucky man to still have all my original 4C sensors, though I did discover once I got my vida that one of my rear position sensors is way off output wise compared to the other, but their delta-v are the same when the car changes height so it appears to be doing well despite the diff.
 

·
Registered
Joined
·
2,045 Posts
I feel like a lucky man to still have all my original 4C sensors, though I did discover once I got my vida that one of my rear position sensors is way off output wise compared to the other, but their delta-v are the same when the car changes height so it appears to be doing well despite the diff.
Check and make sure that the accelerometer in the trunk is not unbolted and rolling around. All you have to do is pull back the little cover on either side of the trunk to check. My drivers side had one laying in there with the bolt laying next to it. Googled the location of where it went in and sure enough there was a bolt hole that that bolt fit in to hold it there.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
8,055 Posts
Not the rear accelerometer in rear, I was referring to the two rear wheel position sensors. Checked all the accelerometer outputs from around the car and they looked good.

Thank god for DICE, it really allows you to be proactive in looking at how your electronics and systems are doing, but then again being a systems engineer helps too, lol. :p
 

·
Registered
Joined
·
2,045 Posts
Not the rear accelerometer in rear, I was referring to the two rear wheel position sensors. Checked all the accelerometer outputs from around the car and they looked good.

Thank god for DICE, it really allows you to be proactive in looking at how your electronics and systems are doing, but then again being a systems engineer helps too, lol.
It has saved me many of times. I hated the short period of being an R owner without vida/ dice. Even when I payed to have the codes read and diagnosed they always got it wrong.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
528 Posts
Discussion Starter · #14 ·
Check and make sure that the accelerometer in the trunk is not unbolted and rolling around. All you have to do is pull back the little cover on either side of the trunk to check. My drivers side had one laying in there with the bolt laying next to it. Googled the location of where it went in and sure enough there was a bolt hole that that bolt fit in to hold it there.

From my electronic gismo- Galaxy S6
Where is this one located?
 

·
Registered
Joined
·
1,025 Posts
I got mine for $160 at Tasca - still not cheap but better than $220.
 

·
Registered
Joined
·
1,398 Posts
I'm selling him a used one for $20 shipped :D
 

·
Registered
Joined
·
2,045 Posts
That's a steal! Easy install man just follow the wire to the plug up on top of the firewall.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
528 Posts
Discussion Starter · #20 ·
I replaced the whole thing. It may have been hard to do just redo the wiring as it was broken inside the sensor.

Sent from my HTC One using Tapatalk
 
1 - 20 of 29 Posts
Top