SwedeSpeed - Volvo Performance Forum banner
601 - 620 of 624 Posts

·
Registered
Joined
·
289 Posts
Decided to change front lower control arms with bushings. Took me about 3 hours to do both sides, including welding a bolt to new control arm for the headlight adjustment.
And guess what? The vibration which i had for 2 years is gone! During these two years i have changed both engine mounts, cv axles, struts, and some more things. Never would have thought that control arms can cause this much vibration.
Now i just need to change torque mount.


Sent from my iPhone using Tapatalk
An update to this. Today had an 300 mile trip, and noticed an small vibration when accelerating. Thought that torque mount will fix this (was planning to change it during the winter). Anyways, at one point something went totaly wrong and now the vibration under acceleration feels like an washing machine when its going in full speed. When i stop and put in P, whole car shakes and rattles weirdly, after putting in N, all the noises and vibrations disappear. Looks like its time to put the c70 in winter sleep and start to remove the “good” old aisin 5 speed automatic transmission.


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
An update to this. Today had an 300 mile trip, and noticed an small vibration when accelerating. Thought that torque mount will fix this (was planning to change it during the winter). Anyways, at one point something went totaly wrong and now the vibration under acceleration feels like an washing machine when its going in full speed. When i stop and put in P, whole car shakes and rattles weirdly, after putting in N, all the noises and vibrations disappear. Looks like its time to put the c70 in winter sleep and start to remove the “good” old aisin 5 speed automatic transmission.


Sent from my iPhone using Tapatalk
That’s weird. Any typical bad transmission noises?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
289 Posts
That’s weird. Any typical bad transmission noises?


Sent from my iPhone using Tapatalk
Only the vibration when its in P. But very unusual to be honest. Never heard or had anything like this. Gears shift with no problems.


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
Mine had a vibration under heavy acceleration. At that time I had new mounts with the exception of the transmission one. It stopped doing it when I replaced it.

What are the odds one of the mounts failed prematurely?. Because if there was an internal failure in the transmission that causes a severe vibration like that, by this point you should have heard something or made a new "inspection window" in the trans case.
 

·
Registered
Joined
·
289 Posts
Mine had a vibration under heavy acceleration. At that time I had new mounts with the exception of the transmission one. It stopped doing it when I replaced it.

What are the odds one of the mounts failed prematurely?. Because if there was an internal failure in the transmission that causes a severe vibration like that, by this point you should have heard something or made a new "inspection window" in the trans case.
All of the engine/trans mounts have been changed during last summer and during winter. I have driven something around 7k km (4-5k miles) since then.
Im surprised that there are no inspection windows, but something is wrong with the transmission for sure.
During next week will call guys who repair auto transmissions, will see what they can tell. Either this one is restorable or will have to look for a replacement one.

Oh and also noticed just now when im slowly driving, sounds like somekinda bearing or something at one point of rotation is making a weird noise. In the transmission ofcourse

P.S. I have been trying to find the cause of vibration since i bought the car, but it was bearable. Have changed both cv axles, mounts, control arms, struts.


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
All of the engine/trans mounts have been changed during last summer and during winter. I have driven something around 7k km (4-5k miles) since then.
Im surprised that there are no inspection windows, but something is wrong with the transmission for sure.
During next week will call guys who repair auto transmissions, will see what they can tell. Either this one is restorable or will have to look for a replacement one.

Oh and also noticed just now when im slowly driving, sounds like somekinda bearing or something at one point of rotation is making a weird noise. In the transmission ofcourse

P.S. I have been trying to find the cause of vibration since i bought the car, but it was bearable. Have changed both cv axles, mounts, control arms, struts.


Sent from my iPhone using Tapatalk
Try jacking up the front of the car. Both wheels in the air, fire it up, put it in gear and you'll have a chance to find that weird noise. Plus, you'll will get a chance to film a video of how bad the engine/trans is shaking.
 

·
Registered
Joined
·
289 Posts
Try jacking up the front of the car. Both wheels in the air, fire it up, put it in gear and you'll have a chance to find that weird noise. Plus, you'll will get a chance to film a video of how bad the engine/trans is shaking.
Yep, will try to do this monday when i have an access to a car lift.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Facusan

·
Registered
Joined
·
220 Posts
New shoes! Continental Control Contact SRS mounted up on my $100 Mirzams. Also installed iPd swaybar end links up front and the Whiteline anti-lift kit on the LCAs. So far it’s an immediate improvement in handling with a little firmer ride.
Wheel Tire Car Land vehicle Vehicle
 

·
Registered
Joined
·
220 Posts
And my Snabb intake pipe arrived! Installed it during halftime. Love the sound and throttle response.
 
  • Like
Reactions: Facusan

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
And my Snabb intake pipe arrived! Installed it during halftime. Love the sound and throttle response.

Did you have to trim the bracket like this to make it clear the A/C lines?




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
220 Posts
Did you have to trim the bracket like this to make it clear the A/C lines?
Right now it's not bolted down on the valve cover, and while it's basically up against the AC lines it's not making noise or anything...yet. I'm going to loosen the motor mounts, shove the motor as far forward as I can, and see if I can improve the fit at all. I'll trim the bracket if need be.

But overall I'm pleased, I get just a little more intake noise, and the throttle response is definitely better. I've also got the iPd air filter, GoVo ECU spacer, and a billet compressor wheel, so it all adds up.
 
  • Like
Reactions: Facusan

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
Mine rubbed the A/C lines a little bit, but didn’t make any noise when it happened. I did what you said, pushed the engine forward as much I could and trimmed the bracket and got ~1/2 inch of clearance.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
220 Posts
Scored a wind deflector with storage bag for $175 on offerup! Yeah, just in time for the rainy season.
 

·
Registered
Joined
·
289 Posts
All of the engine/trans mounts have been changed during last summer and during winter. I have driven something around 7k km (4-5k miles) since then.
Im surprised that there are no inspection windows, but something is wrong with the transmission for sure.
During next week will call guys who repair auto transmissions, will see what they can tell. Either this one is restorable or will have to look for a replacement one.

Oh and also noticed just now when im slowly driving, sounds like somekinda bearing or something at one point of rotation is making a weird noise. In the transmission ofcourse

P.S. I have been trying to find the cause of vibration since i bought the car, but it was bearable. Have changed both cv axles, mounts, control arms, struts.


Sent from my iPhone using Tapatalk
Update.
Drove with the c70 to gearbox specialists. They did a couple of test drives, put the car on a lift, checked everything. And they came to conclusion that the gearbox is fine, it just needs an oil change. They recomended to check the engine first. In the few upcoming weeks will remove the injectors and take them to test, got a feeling that one of them isnt working at all.
No idea why didnt i think of this in the first place.
P.s. Should i make a new topic about my c70 and adventures?


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
Update.
Drove with the c70 to gearbox specialists. They did a couple of test drives, put the car on a lift, checked everything. And they came to conclusion that the gearbox is fine, it just needs an oil change. They recomended to check the engine first. In the few upcoming weeks will remove the injectors and take them to test, got a feeling that one of them isnt working at all.
No idea why didnt i think of this in the first place.
+1 about the oil change. Volvo says the trans oil is for lifetime (yeah..... of the warranty) which is simply outrageous.

Have you checked for DTC codes? any check engine light?


P.s. Should i make a new topic about my c70 and adventures?
YES
 

·
Registered
Joined
·
289 Posts
+1 about the oil change. Volvo says the trans oil is for lifetime (yeah..... of the warranty) which is simply outrageous.

Have you checked for DTC codes? any check engine light?



YES
No DTC codes. Just to remind, i got a diesel engine, D5
Anyways, i havent checked the corrections of the injectors. Might check them in the weekend.
And must agree about the oil change. My plan was to change it during the winter.

Alright, will make an topic in the evening, will ad some pictures of the car aswell.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Facusan

·
Registered
Joined
·
1,487 Posts
Scored a wind deflector with storage bag for $175 on offerup! Yeah, just in time for the rainy season.
It makes a great temporary prop to hold up the front of the headliner when it drops unexpectedly ;)
 
  • Like
Reactions: Facusan

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
Intercooler and charge pipe upgrade day!






Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
Intercooler and charge pipe upgrade day!






Sent from my iPhone using Tapatalk

So, I finished installing the intercooler and charge pipes this afternoon. Installation took some time to get everything lined up, but overall it was simple. The charge pipe mounting points were a little bit off, didn't go all the way up against the block. But I managed to solve this by using longer bolts and extra washers as spacers. I only had to trim 1/4 inch of the lower grille tabs because they rubbed against the intercooler. Once I put all back together, the intercooler is almost unnoticeable. Only way to find out is if you either know how far back the stock IC is or if you compare it with a stock C70. So while there was still some daylight left, I washed the car and took it for a test drive during the evening.

Ambient temperature was 64F/17C. First drive was weird, it felt laggy and weak while driving through the neighborhood. Intake temps were barely a few degrees hotter than ambient. The hottest I saw it was 78F/25C, while parked idling with the A/C on for 15 minutes. But when I started driving, temps quickly dropped to almost ambient. After a few miles and a couple drive cycles, the engine responsiveness improved a lot, but not like before, kinda close, turbo lag is still more noticeable and definitely louder than before.

Then it was time to get on the "Mexican" freeway and OH BOY!, What a difference!, although the max boost pressure now only gets up to 8.5 psi (previously max recorded boost was 10 psi) butt-dyno results says it's definitely quicker than before. I reached 130mph with much less effort, either in 4th or 5th gear. This probably is because now the engine gets a denser intake air charge.

I also have a 70mm Porsche Throttle body I wanted to install today along with the intercooler and pipes. But I couldn't get the correct bolts to mount it to the plastic intake plenum.

Tire Wheel Car Vehicle Automotive tire


Furniture Outdoor bench Table Wood Outdoor furniture


Car Wheel Vehicle Vehicle registration plate Tire
 

·
Registered
2007 S40 2.4i / 2007 C70 T5
Joined
·
1,111 Posts
I also have a 70mm Porsche Throttle body I wanted to install today along with the intercooler and pipes. But I couldn't get the correct bolts to mount it to the plastic intake plenum.
I finally installed the Porsche throttle body. Turns out the stock plenum bolts are long enough.

Car Hood Motor vehicle Vehicle Automotive design



One difference I've noticed when compared to the stock TB, besides the 5mm bore diameter, is that the butterfly valve center is ~33mm away from the plenum instead of ~23mm of the stock unit.

Product Gas Household hardware Font Metal


Automotive tire Font Tire Gas Machine


So, this 10mm spacing and bore difference adds approximately 43.78 cm3 to the plenum volume. This probably helps achieving more power at high rpms.

I took the car for a test drive, And despite many posts saying this TB will make the throttle response more sensitive. To me, it feels the same when driving normally, but I've noticed a slight improvement at full throttle.
 
601 - 620 of 624 Posts
Top