SwedeSpeed - Volvo Performance Forum banner

441 - 460 of 525 Posts

·
Registered
Joined
·
28 Posts
wait... we can do that in VIDA?

I really need to spend some time poking around the app.
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
wait... we can do that in VIDA?

I really need to spend some time poking around the app.
You can, but with a legit vida subscription, which costs $80 for a 3 day license, plus the cost of every sw you download. The “Master key app” costs $36.32 . Like most of the available softwares. Others can cost up to $300 like the “Add trip computer” sw.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
28 Posts
You can, but with a legit vida subscription, which costs $80 for a 3 day license, plus the cost of every sw you download. The “Master key app” costs $36.32 . Like most of the available softwares. Others can cost up to $300 like the “Add trip computer” sw.

Ok, so that's reasonable. Works with "non-official/ebay" dice units?

Guess I need to see how I can figure out what, if anything is actually or available needed on my cars and then go from there. May just have to pony up the $80 and see what happens.
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
Ok, so that's reasonable. Works with "non-official/ebay" dice units?

Guess I need to see how I can figure out what, if anything is actually or available needed on my cars and then go from there. May just have to pony up the $80 and see what happens.
Yes, it works with "non-official" dice units. mine came from ebay. VIDA shows you a list of available SW upgrades, Function and Hardware changes (for the last one Vida performs a readout of every module before showing you the available softwares.

Remember, $80 is the cost of the 3 day subscription. then you have to add the price of every software you download on top of that. For example: adding a key will cost $115.60 just in software + the cost of a new key.

If you already have a ebay Dice unit and VIDA 2014D. then, it doesn't make any sense to purchase the subscription unless you plan to do Software downloads.
 

·
Registered
Joined
·
462 Posts
Just got this back from the paint shop today, going to have it installed tomorrow...
 

·
Registered
Joined
·
1,352 Posts
Installed a new brake pedal pad...:D
I did LESS!!
After getting a summer's worth of rain this week, I finally washed and cleaned ours today!!! Supposed to be a beautiful weekend to show it off!!!
 

·
Registered
Joined
·
462 Posts
Before and after install of Heico diffuser. Needed some modification of my exhaust system...
 

·
Registered
Joined
·
170 Posts
Either a bad angle of pic or i was expecting it to look better. Can we get a different angle picture?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
462 Posts
Either a bad angle of pic or i was expecting it to look better. Can we get a different angle picture?


Sent from my iPhone using Tapatalk
I'll take another picture when the car is clean. The diffuser is actually quite subtle when you see it from the back, you don't really see the fins between the exhaust pipes.
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
To me, looks great!
Good thing he already had bigger tailpipes.
The stock ones wouldn’t look right with that diffuser.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
975 Posts
So according to my mechanic my aforementioned awful noise is in fact the AC compressor needs replacing... don’t really see the point of spending $600ish on something that apparently lasts about 12 years, since the rest of the car isn’t going to last that long... considering a used replacement from Erie - thoughts?
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
Did he say if it was the a/c compressor pulley bearing or the actual a/c compressor?


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
The reason I asked about if it was the pulley is because the bearing should be replaceable. That would avoid you having to replace the compressor and all the work related to that (A/C system drain, removal & replacement of compressor, A/C system charge, etc). In other words, it should be cheaper.

The T5 for some reason cycles the A/C at startup while the 2.4i doesn’t (or at least both mine).

If the A/C compressor is bad, the sound should be heard only on startup (with the A/C off) and then goes away. If pulley bearing is bad, the sound can be heard at all times


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
628 Posts
I spent most of the day cleaning the Volvo before winter arrives.

Wash, debugged, clay bar, buffed and waxed.

She still cleans up nice for a 9 year old 120,000 mile car.


Sent from my moto x4 using Tapatalk
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
Yesterday installed new akebono front brake pads and the OEM strut brace.





Also I cleaned the exterior of the power steering pump because it was full of oil/dirt. Not sure if is leaking or somebody before I bought the car spilled oil while topping it up.


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
Installed new rear shock absorbers, bump stops and mounts.



It was so easy to replace I didn’t even had to remove the wheel!!

I just put the back of the car on jackstands and 20 minutes later the car was on the ground again. The only difficult part was torquing the shock absorber/control arm bolt with the car on the ground.



Also replaced the left headlight harness connector that had the release tab broken and every time had to use a flat head screwdriver to disconnect it from the headlight.





Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,352 Posts
Cool ....how many miles on your ride? Did you "need" new shocks or just wanted a change in performance? What was the cost of parts?
 

·
Registered
Joined
·
170 Posts
Changed both front shock absorbers including upper bearings. Also had to change one of the lower ball joints, that was a bit of pain in the ass. Tried flexing off the rivets, but that didnt help, ended with drilling them out. Too bad didnt thought abiut drilling them out in the first place.
Also not bad for oem ball joint (290k km).


Sent from my iPhone using Tapatalk
 

·
Registered
2007 S40 2.4i AW55-50 / 2007 C70 T5 AW55-50
Joined
·
456 Posts
it has 99500 miles. I replaced the shocks after I found they had lost their nitrogen charge. When I pushed the shock rod, it didn't go back to its fully extended position.
Initially I was going to replace the bump stops, but when I removed the shock. I found out they were gone.

the cost of the parts was:

Shock Absorbers: $78.76 (eeuroparts.com / KYB 348082)

Shock Absorber mounts: $35.18 (eeuroparts.com / Lemforder 3131801)

Bump stop & dust cover kit: $19.99 (FCP Euro / Meyle 5147400000)
 
441 - 460 of 525 Posts
Top