SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 37 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
Hello all

I was wondering what this part (see pics) is.
It looks broken to me





Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #2 ·
I’m thinking it’s an engine mount...

Looks like the rubbers are deteriorating a little


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #5 ·
It's your upper torque rod and yours needs to be replaced.
Thanks tech. I’ll get onto it


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #6 ·
Yup, that's one shot engine mount.. I'd see a dealer ASAP.

Out of curiosity- what engine/model yr?
Thanks Torsen. It’s a 2016 xc90 inscription.... B4204T27

Done around 55000 kms


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #7 ·
It looks like heat damage to me


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #9 ·
Discovered today that the car is still under factory warrant for a couple more months.
This item is covered (part #: 31330590) so is being replaced on Friday


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #11 ·
Besides visual inspection, are there any symptoms to look out for?
Hi RyVolvo
I don’t drive the car much these days but I did notice a few jerky shifts over the weekend. And also one really rough shift...I’ll possibly be able to feel a difference on Friday when the replacement is in. Will let you know

As far as acceleration from 0...it’s been a bit laggy but I was putting that down to the learning algorithm. Even though I’ve set up two profiles, only one key has held its value so often when my wife drives the car, it’s set to my profile.
Kinda defeats the purpose and I just wish they’d let go of the learning idea and just make it perform like the rockstar it is when it’s “fresh”


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #18 ·
Ok, so it's not something one can cause or avoid.
Don’t drive the car will avoid all problems


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,918 Posts
Wear and tear. It's a rubber engine mount basically. It wears out.
So is it covered if still within warranty? Seems not normal worn out so early.

Fusion · Red · T8 · XC60
 
1 - 20 of 37 Posts
Top