SwedeSpeed - Volvo Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Weird Noise at above 2500RPM

Hey guys,

I have a weird noise happening whenever the car is above 2500 RPM parked or driving. Not too sure what it is. Here is a link to a video of the sound https://www.youtube.com/watch?v=ybibOY-tLA8.

Has anyone heard this in their car before? Driving a 2015 Volvo V60 R-Design Polestar T6. Thank you in advance!!!
 

·
Registered
Joined
·
63 Posts
That’s weird alright.

Similar to our 2016 s60 t6 awd r-d p-opt with polestar racing exhaust.

Drive-e t6 drivetrain is complex, lots of systems running in concert that make different sounds. Once opening up the air intakes sound with the thin paper air filter in the PS exhaust kit, mechanically loud sound from the supercharger phases in and out constantly.

Once the clutch coupled supercharger disconnects, turbocharger noise is nearly or fully undetectable.

Thankful for the extended warranties purchased. T6 Drive-e 2.0l hasn’t been trouble free for all, our 2016 at 45600 mi has performed extremely powerfully to a fault, interrupted only by fuel injector replacement of 2 cylinders.
 

·
Registered
Joined
·
13,510 Posts
Hi just checking in to see if anyone has had this noise on their Volvo before.
I've never heard that on the three T6 six cylinder cars I've owned (still have two).
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thank you guys for chiming in. This noise is driving me crazy and I can't isolate it. Idk if I should take it to a shop and give them my arm and leg or start buying and replacing parts myself to see if it's something simple. But i'm worried if it's something more complex i dont want to be sinking money into it.
 

·
Registered
Joined
·
13,510 Posts
I wouldn't even know where to start if you were to consider throwing parts at it. If it bothers you I would take to a shop (dealer or indy you trust) to have them take a look at it. It almost sounds like a pulley or something as it's rev dependent and car was not moving.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Thank you. That’s where I was taking of starting. Maybe replacing the tensioner. Though the car only just hit 40k miles so I would think none of that is worn yet.

It’s just a weird noise. I think it’s also weird that it only happens once the car it heated up to operating temp. When it’s cold nothing happens.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Could this problem be caused by bad gas? Put a fuel stabilizer/injector cleaner into the car, ran it hard to empty and filled back up with Shell Premium. Noise is gone.... like it was never there.

I didn't think gas would make that much of a difference??? I was using Costco premium before. Has anyone ever heard of other effects of gas on a car?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
I agree it's so dumb crazy! I really don't know where the sound came from or where it went. starting to think it was a phantom noise or my cause is haunted by a dead alternator lol.
 
1 - 10 of 10 Posts
Top