SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1 (Edited)
Hey all,
I have a weird noise at high boost that is accompanied by a serious non-stuttering decrease in power. When I let off the pedal, it stops and the car drives normally. It doesn't sound like a boost leak, and my car runs fine under regular throttle - it's just when I stomp on it that this happens, and it just started happening. It kind of sounds like valve chatter or a faulty solenoid. I'll try to borrow a recorder and upload the sound. What does a faulty TCV or CBV sound like? Any links to those sounds?
Thanks.
 

·
Registered
Joined
·
2,418 Posts
Can't really picture the noise you're describing.. Remove the inlet pipe, and check to make sure all your vac lines are connected properly.
 

·
Registered
Joined
·
233 Posts
Possible a bad coil? Sound like a past turbo car of mine when a coil went bad. It was good enough to run but as the boost increased, the spark decreased and caused a horrible stutter at wot or high boost. Do you have a cel on? The car should pick up on the missfires.
 

·
Registered
Joined
·
3,313 Posts
I had a similar problem, turns out a cracked spark plug on the ceramic housing was the culprit.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
The noise is like a high pitched buzz. I know the stutter caused by a bad coil, cuz I had that awhile ago. Now the car has brand new IPD HD coil packs and new plugs in it. The CEL didn't go on at all through or after the incident. Cracked spark plug... should that throw a CEL? I'll check all my piping tomorrow and report back.
Thanks.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #6 (Edited)
Never knew my non-smart phone records video until now... It sounds more like someone trying to play a note on the trumpet now that I'm listening to it...
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
Okay, I have the upgraded CBV from VIVA sitting in my garage. I'll put that in when my time frees up in a couple of weeks. I had to drive the car recently and it is getting worse; now at lower throttle power gets cut instantaneously until I let off the throttle, but it doesn't make any sound. It isn't a stutter, it just feels like I all-of-a-suddenly took my foot off the pedal.
 

·
Registered
Joined
·
528 Posts
Don't see a boost gauge in your sig... do you have one? Would help to see your boost level when this happens.
 
1 - 9 of 9 Posts
Top