SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,480 Posts
Discussion Starter · #1 ·
For about 100k, I have had an Aquamist system installed on the car. I installed it according to the recommendation from Aquamist back in the day. The boost pressure switch is tapping into the line going from the turbo to the TCV. It is set to activate at 10psi. Now thinking about it, shouldn't that boost pressure switch be reading from the intake manifold, i.e. the same line that is tapped for a boost gauge?

Where is everyone reading boost pressure for the switch? Comments please.
 

·
Registered
Joined
·
4,272 Posts
I am reading the PWM signal going to one of the fuel injectors. Sounds like you are running the 1S system which is not a progressive system
 

·
Registered
Joined
·
1,480 Posts
Discussion Starter · #6 ·
lol.

Can anyone see any problem running both a boost gauge and the boost pressure switch off the same port on the manifold? I can't think of it being a problem.
 

·
Registered
Joined
·
3,480 Posts
lol.

Can anyone see any problem running both a boost gauge and the boost pressure switch off the same port on the manifold? I can't think of it being a problem.
My car is set up like that and works fine.
 

·
Registered
Joined
·
2,165 Posts
Same as most users running a boost switch tapped off the intake manifold. I have mine set from 10psi to begin at 10% and progressively increase 10% every psi until 20psi for 100% flow. Labonte Stage II setup.

No issues. :)
 
1 - 8 of 8 Posts
Top