SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
Hey all... I've seen this one on the web a few times but no solutions. The passenger side of the cabin is blowing hot air. I pulled the AC controls and radio to listen to the blend doors. The driver's side blend door is quiet while the passenger is loud and for lack of a better term: clicky. The thing is, it sounds like it's moving, just making noise while doing so. The problem is a bit more complex though...

The door only moves on the last two notches of the passenger side temperature knob. So if I move it from hot to one notch before that it sounds like it's moving but if I move it any where else between cool and one notch before all the way hot, it doesn't even attempt to do anything. The amount it's moving between that one notch is a lot though. Basically all the way hot is all the way hot but one notch before that and it moves the blend door enough so that is pushing lukewarm air, slightly cooler than ambient. So I think I'm dealing with a blend door that's beginning to fail but still working and a bad passenger side temperature knob. Does that sound about right?

Do the controls fail?
 

·
Registered
Joined
·
11,628 Posts
I believe there's a Temperature Calibration that can be done in VIDA/DiCE (the software that can access the car's computer). What year is your XC?
 

·
Registered
Joined
·
2,486 Posts
It's not the knob.

I had a similar problem with my T5; it was fixed on warranty.

There was something wrong with a passenger side servo. The funny thing was that the tech could not duplicate it on the bench. When the unit was installed in the car, the whole thing was under tension and made the air flaps sticky. The servo was not strong enough to move the flap. It's not a very cheap repair if out of warranty. If it happened to my XC, I'd try throwing in a salvage unit and having it recharged and calibrated.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #4 ·
Truck is a 2004 guys. Mika, if you could dig up the paper work and see what they replaced I'd be forever indebted. I assumed it wasn't the knob or control unit but I've never seen a problem like that before.
 

·
Registered
Joined
·
1,804 Posts
i could be as simple as low refrigerant...
if an 05+ possible LIN bus failure due to a seat heater module...
or a pass temp damper motor on all years
 

·
Registered
Joined
·
2,486 Posts
Mike I don't have the paperwork anymore, but it was the damper motor that they replaced. Thanks garbetski for the right term.
 
1 - 6 of 6 Posts
Top