SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Reoccuring DTC's on 99 S70 which otherwise runs ok<p>P0600 (reported by sensor #122)<br>P1057 (reported by sensor #122)<br>P0722 (reported by sensor 31)<br>and sometimes, but not always<br>P1081 (reported by sensor #122)<p>READ....BACKROUND: below for more info and previous history of problem<p>I have been told by a retired professional Volvo mechanic that the underlying problem causing these DTC's to re-appear is the ANTENNA RING around the ignition key hole (the communication link between chip in key and the vehicle) Recomendation: take car to dealer have ANTENNA RING replaced and reprogrammed, and see if DTC's reoccur, before doing any other repairs, such as repair ABS Module or Transmission Speed Sensor (as sugested by one Swedespeed member a few months ago? I am inclined to follow this advice, because it comes from a highly regarded local source.<p>Any thoughts, advice, reaction from Volvo community welcome.<p>Thanks,<p>J.C.<p>P.S....As noted above, info below comes from previous 4-4-09 inquiry.<p>Background:<br>1999 Volvo S70 2.4L NonT 122K (bought used at 38K 2003) Generally reliable for 4 yrs, expensive last year and a half. Seen the old ChkEng Light too much, too many trips to Dealer. Never sure whether I am getting honest info. Never sure the Dealer really knows what they are doing, or actually did work billed, since several problems reoccured. Bought OBD2 device to read codes (DTC's) on my PC.<p>TWO WEEKS AGO 3-20-09<br>Car runs fine but ChkEng Light comes on. OBD2 DTC's = (4) <br>P1081 (Immobilizer Communication?),<br>P0600 (Serial Communication Link Malfunction),<br>P0722 (Transmission Speed Sensor Missing or Output Speed Sensor Circuit -No Signal),<br>P1057 (?Not sure?- Possible TCM Fault- Possibly involving Throtle Module - opinions & sources vary)<br>I erase all codes and turn off ChkEng Light with OBD2 device & computer.<br>Vehicle drives fine for 2 weeks (60-80 miles, mostly local, some highway.<p>THREE DAYS AGO<br>Hook up OBDCOM device to Vehicle just to see if any codes have returned.<br>Scanner Program reports CODE P1081 is stored, but ChkEng Light has not come on. No other codes are reported. Vehicle continues to drive fine.<p>YESTERDAY (10-12 miles later)<br>ChkEng Light come on again. I hook up OBD2 device and PC to car to read codes and monitor and record vehicle operation and sensor data while driving. OBD2 DTC's = (4) The same four DTC's as before.<br>P0600 (reported by sensor # 122)<br>P1057 (reported by sensor # 122)<br>P1081 (reported by Sensor # 122)<br>P0722 (reported by sensor # 31)<p>DTC's are reported in the order listed.<br>See definitions of DTC's above - (as far as I can determine definitions)<p>A minute or two later, the (lighted) upward pointing ARROW starts flashing continuously in the instrument pannel window where the ChkEng Light and other warning lights are located. Car still in PARK. (This lighted arrow usually only appears when the vehicle is in a gear below D, and then it stays on {not flasing} until the shifter is moved up to D. Engine still ran smooth, so I took the car for a short drive hooked up to the computer, and recored operational data.<p>A mile or two later, while on the higway, the ABS and BRAKE lights came on then turned off, and repeated this cylcle intermitently throughout the drive. The speedometer also stopped working (or dropped to zero while driving 60MPH) and the odometer reading turned into a line of dashes, then both came back on, and repeated a cycle of intermitent malfunction throughout the drive. Please NOTE, the vehicle continued to operate normally and the brakes worked fine.<p>SO NOW WHAT SHOULD I DO?<p>I won't be fixing it myself, but I hate to take it to the dealer for another expensive round of repairs that may, or may not, all be necessary and may, or may not, actually fix the car.<p>I have an honest local mechanic with some, but not lots of diagnostic equipment. He will competently do what I ask him to do, but it is better to know what work needs to be done or parts replaced. Then he will do what I asked for a fair price.<p>Any constructive advice or suggested solutions would be appreciated, hopefully from guys (or women) who know what they are talking about.<p>Thanks.<p>JC
 

·
Registered
Joined
·
1 Posts
I have similar problem with my VOLVO S70 1999 FWD Base model.
None of the local mechanic is able to understand what the problem is and giving me wrong sugestions.
Can you please answer me how did you get this fixed ?

I read in few other blogs that changing the antenna ring will help fix the problem.
Not sure will that solve the problem or its just another wste effort to fix this issue.
Where can i purchase the antenna ring. Deals are changing $75 just for ring.
 

·
Registered
Joined
·
2,887 Posts
The OP made 2 poses 3 years ago. You probably won't hear much from him.
And "similar" doesn't tell us about YOUR car. Every problem is different.
If you're looking for helpful assistance, you really need to take the time to
elaborate on your particular issue. Details? Codes? History? Mileage?
 
1 - 3 of 3 Posts
Top