SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
658 Posts
Discussion Starter · #1 ·
So, I just installed an Elevate rear anti-sway bar on my 2005 S40 2.4i which took me maybe an hour. However, the vinyl decals I purchased have taken twice this long to figure out! Problem? The "sticky part" is adhering to a thicker vinyl sheet more than the "masking tape" part and shouldn't this be just the opposite?

The lettering is sticking to the thicker vinyl piece behind it, making it impossible to take off and apply to the window.

I must be missing something here. However, I did notice the decals from Elevate vary. I got some blue decals which seem to adhere to the masking tape just fine because they have a different backing--they don't have this thick backing, but the red decals I got, have the thicker backing, making the lettering stick to it like glue.

Any ideas? Is there anyone else who has purchased the red ELEVATE vinyl decals?

I'm about to just create my own in Photoshop lettering and send it to somebody online to create.
 

·
Registered
Joined
·
4,563 Posts
Can you get to the point of actually putting the decal on the window? Or is the decal not separating correctly to be able to put it on?
Can you take a pic of exactly what you're talking about?
 

·
Registered
Joined
·
658 Posts
Discussion Starter · #3 · (Edited)


Thanks for the response. There yah go. The answer to your first question is no, I can't even apply the decal to the window because the side that peels away is not sticky at all. The stickier side is stuck to the clear vinyl backing.

You may not notice entirely by the pic, but the decals have the same size lettering, but two totally different "backing". The blue decal separates just fine, but the red decals have this clear and thick vinyl backing. Can take more pics if necessary. I actually have a silver decal of the same size as well that came with another product and also does not have this thicker vinyl backing like the red decal.
 

·
Registered
Joined
·
4,563 Posts
I get what you're saying. I wonder if temperatures might have anything to do with them not separating correctly.
I'd call Elevate and see about him sending replacement decals if you really want them in red.
By the looks of it, you'd be able to apple the other colors is that correct? If so you might have to rock the blue or silver ones.

Good luck and welcome to the forum!!!
 

·
Super Moderator
Joined
·
15,155 Posts
Common problem, I just faced this with my own Elevate stickers.

What I did, was simply apply a LOT of pressure over each letter with my thumb and forefinger. Basically, getting it as stuck as possible to the clear sticky sheet. After doing that for 30 seconds, it pulled right off of the waxy paper and was ready for application.
 

·
Registered
Joined
·
658 Posts
Discussion Starter · #6 ·
Thanks for the tips, guys. Will do.

This forum has A LOT of answers to questions I had, and already saved me a good deal of money.
 

·
Registered
Joined
·
658 Posts
Discussion Starter · #7 ·
Thanks to MyNameIdeasWereTaken.

1) Applied A LOT of pressure with my thumb to ONE LETTER at a time,

2) Raised tape, then to the next letter.

Works well. :thumbup:
 
1 - 8 of 8 Posts
Top