SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 178 Posts

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #1 ·
Idle fine, rev to any rpm, fine, steady cruise fine, light to moderate acceleration fine , WOT I get a vibration, not suspension related it has nothing to do with speed, I can go triple digits no vibration. Only under full throttle starts around 3500 rpm. I'm thinking motor mounts? I already replaced the torque mount. It's coming from the engine bay.
 

·
Registered
Joined
·
3,256 Posts
i get this same vibe under wot sometimes. i thought maybe turbo so i just try to ignore it. :p but it might be mount related. never touched any of the mounts in the bay.
 

·
Registered
Joined
·
9,114 Posts
Sounds corny but drive with no hood and watch engine movement maybe? Could be mounts I suppose.
 

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #4 ·
Well,I ordered 2 mounts from IPD, I'll throw them in on Friday. Mounts were my first guess, there are not expensive. I don't really have any other ideas except bad ones, lol.
 

·
Registered
Joined
·
9,114 Posts
I take it aftermarket ones are unavailable? Realistically the lower mount should control the torque of the motor.
 

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #6 ·
I don't know of any aftermarket mounts, I just ordered oem.
 

·
Registered
Joined
·
9,114 Posts
U buy any wheels yet? Should get some and enter the Import Meet show next month ;)
 

·
Registered
Joined
·
4,372 Posts
I assume you have the upgraded lower mount (aftermarket or improved factory Volvo) & have already replaced the right upper at least once. You have an 05'... Have you replaced the upper trans mount with the newer hydraulic mount? There were a few posts where I gave the part number for the kit. PM me your email & I'll send the Tech Bulletin.
 

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #9 ·

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #10 ·
I assume you have the upgraded lower mount (aftermarket or improved factory Volvo) & have already replaced the right upper at least once. You have an 05'... Have you replaced the upper trans mount with the newer hydraulic mount? There were a few posts where I gave the part number for the kit. PM me your email & I'll send the Tech Bulletin.
Yes I have aftermarket lower mount but have not upgraded the upper mount, I'll see what the motor mounts do first.
 

·
Registered
Joined
·
41 Posts
I am having this exact same issue with my 06 2.4i. Only happens under hard acceleration. Is this mostly a motor/trans mount issue? Doesn't seem to be much info floating around about this.

Sent from my DROID RAZR using Tapatalk 2
 

·
Registered
Joined
·
837 Posts
what is this hydraulic motor mount upgrade?
 

·
Registered
Joined
·
3,256 Posts

·
Registered
Joined
·
4,372 Posts
S40 & V50 customers may complain of a clunking noise during shifting or when applying and releasing the accelerator pedal. It is especially noticeable on cars with manual transmissions during low speed driving and when making a 1-2 shift. The customer may also complain of a slight vibration through the floor or seat at low engine RPMs (approx 1800-2000).
It's the mount for the transmission. Only applies to early cars, later cars came with the hydraulic mount from the factory. Check your car & compare to the pics below.



 

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #16 ·
Thanks for posting that! I'm not sure that's my problem, my problem only occurs at WOT and at higher RPM's, right where the meat of the torque curve is. I'm pretty sure the motor mounts are worn and the engine is moving more than normal under heavy load, causing some kind of misalignment, I'll know tomorrow.
 

·
Registered
Joined
·
837 Posts
It's the mount for the transmission. Only applies to early cars, later cars came with the hydraulic mount from the factory. Check your car & compare to the pics below.



where is that ordered from? Thanks so much ive been dealing with this for a while and this is the first iver heard about the upgrade
 

·
Registered
Joined
·
4,372 Posts
These are factory Volvo parts. Grab from your favorite dealer.
I can't comment on how effective this will be, just passing along the factory bulletin on a possible vibration source.

You do know that the lower "torque" mount has been upgraded by Volvo as well? Same old part number, just an improved version with more rubber. Maybe someone could post a side by side picture. I have no idea when the new style lower mount went into production. Anyone?
 

·
Registered
Joined
·
837 Posts
These are factory Volvo parts. Grab from your favorite dealer.
I can't comment on how effective this will be, just passing along the factory bulletin on a possible vibration source.

You do know that the lower "torque" mount has been upgraded by Volvo as well? Same old part number, just an improved version with more rubber. Maybe someone could post a side by side picture. I have no idea when the new style lower mount went into production. Anyone?
ya I think viva or ipd sells the upgraded version. I also recall elevate or soemone carrying there own upgraded version of it using a full silicone mount.
 

·
Registered
Joined
·
1,761 Posts
Discussion Starter · #20 ·
Your thinking of the upgraded lower mount, which a lot of people have done, the one pictured above is the upper transmission mount.
 
1 - 20 of 178 Posts
Top