SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2,383 Posts
Discussion Starter · #1 ·
I am driving around in a low mileage 2012 S60 SE Lux at the moment which comes with 17" wheels. I'm finding the ride quality to be very hard and brash over bumps in the road... you can feel every single thing on the road. The first-generation S60 was waaaay more comfortable. This car is not an R-Design, has a high ride-height with massive gaps in the wheel arches so I can't understand why they're like this. Is it the same for all these S60s?
 

·
Registered
Joined
·
8,236 Posts
I am driving around in a low mileage 2012 S60 SE Lux at the moment which comes with 17" wheels. I'm finding the ride quality to be very hard and brash over bumps in the road... you can feel every single thing on the road. The first-generation S60 was waaaay more comfortable. This car is not an R-Design, has a high ride-height with massive gaps in the wheel arches so I can't understand why they're like this. Is it the same for all these S60s?
Bad Struts? Bent Rim? Low Tire Pressure?
 

·
Registered
Joined
·
2,383 Posts
Discussion Starter · #3 ·
Bad Struts? Bent Rim? Low Tire Pressure?
Its only done 20,000 miles so didn't think struts were an issue but I'll ask them to check it out next time. No bent rims as far as I can tell. Tire pressure is set correctly, perhaps a little higher at 38psi but even when it drops to 30psi the ride is just no good.
 

·
Registered
Joined
·
1,833 Posts
I am driving around in a low mileage 2012 S60 SE Lux at the moment which comes with 17" wheels. I'm finding the ride quality to be very hard and brash over bumps in the road... you can feel every single thing on the road. The first-generation S60 was waaaay more comfortable. This car is not an R-Design, has a high ride-height with massive gaps in the wheel arches so I can't understand why they're like this. Is it the same for all these S60s?
I have the same experience here. New struts and mounts all around less than a year ago. I showed it to Volvo mechanic and he looked it over and drove it and says that nothing looks out of order.
I do have the iPD rear anti sway bar so that might have some effect but it can't be that much.
Beautiful ride on the highway but in the city not so much.
 

·
Registered
Joined
·
197 Posts
What brand and size of tires are you running and what does the date code on the sidewall say about their age?
 

·
Registered
Joined
·
351 Posts
Any chance you're on run-flat tires? They are notoriously unforgiving.

Sent from my Galaxy S7 using Tapatalk
 

·
Registered
Joined
·
1,833 Posts
Any chance you're on run-flat tires? They are notoriously unforgiving.
Good point but that's not it.
I'm running on the 17" with regular tires and same thing. Even the winter tires on 16" rims don't make such a big difference.
 

·
Registered
Joined
·
351 Posts
This might be a long-shot, but, given you said there's a high ride high, are the shipping blocks still in the springs? They spread the springs to facilitate loading and offloading the car from haulers.

Sent from my Galaxy S7 using Tapatalk
 

·
Registered
Joined
·
1,833 Posts
This might be a long-shot, but, given you said there's a high ride high, are the shipping blocks still in the springs? They spread the springs to facilitate loading and offloading the car from haulers.
Good shot. Has been known to happen but not the case.
1- I've checked for that a long time ago.
2- I've had all 4 shocks/struts replaced so something like that would have been caught in the process.

Also, where is OP (Token)? Started the thread and disappeared :) :)
 
1 - 9 of 9 Posts
Top