SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hi everybody. <p>Newbie here from Denmark, with an ‘05 V70R MT – Sapphire/Nordkap.<p><IMG SRC="http://img19.imageshack.us/img19/7369/volvo2g.jpg" BORDER="0"><p>I bought the car a little over a year ago from my boss, who had it from new. At that time it had done about 140k miles in 2 years, and then only driven occasionally until I got it. <br>I wanted that car from the first time I saw/drove it….and when he gave me a good price, I couldn’t say no <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0"> <p>It’s a great and rare car, I’ve only seen 2 others in my time with it. But I do wonder how Volvo could put the car in production with rain squeal, side hop and tires rubbing when you turn, right out of the factory. And that truck-like turning circle. Where did they test the car? On nothing but straight, flat and dry roads??<p>Now a question:<p>A couple of weeks ago I put in a KN-filter. No problem.<br>Last week I fitted a BSR-catback exhaust. Pretty easy to do. But when I started the car I got a “Check engine light”. I reset the ECU by pulling the fuses, and it went away for a couple of days. Now it keeps coming back after about 2 days driving.<p>You guys got any ideas why?<p>Any help much appreciated.<p>Car sounds great with it btw <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p>/Henrik<br>
 

·
Registered
Joined
·
4,272 Posts
Re: V70R Newbie from Denmark with question (blackvolvorules)

Cat back should not cause a CEL<p>Did you maybe damage your rear O2 sensor in the process of installing the cat back?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Re: V70R Newbie from Denmark with question (jstro)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>jstro</b> »</i></TD></TR><TR><TD CLASS="quote">Cat back should not cause a CEL<p>Did you maybe damage your rear O2 sensor in the process of installing the cat back?</TD></TR></TABLE><p>Thats what i thought, ive only read DPs could cause CEL.<p>I'll probably have to get under there again and check it out. Allthough I was as carefull as i could be, lying under the car swearing and sweating <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> <p>Thanks.
 

·
Registered
Joined
·
1,578 Posts
Re: V70R Newbie from Denmark with question (blackvolvorules)

I would suggest get a code reader...here in america they let you use it for free in some automotive stores<p>other than that<p>rough engine->MAF related<br>normal engine->O2 sensor/Emissions related (like previous poster said, maybe knocked out sensor when installing catback<p>gl
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
Re: V70R Newbie from Denmark with question (FEO)

Engine is running fine. I'll get under there and have a look at the O2 sensor tomorrow.<p>Code reader: Im actually considering the IPD Softloader, but im not sure how smart it is tuning an engine with this kind of mileage.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
Turns out it was the KN-filter. The O2 sensor looked fine, so I tried putting the stock filter back in. After a couple of days the CEL went away.<p>I guess its bye-bye KN.
 

·
Registered
Joined
·
1,200 Posts
Re: (blackvolvorules)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>blackvolvorules</b> »</i></TD></TR><TR><TD CLASS="quote">Turns out it was the KN-filter. The O2 sensor looked fine, so I tried putting the stock filter back in. After a couple of days the CEL went away.<p>I guess its bye-bye KN.</TD></TR></TABLE><p>While I've heard of it, many of us run K + N filters with no codes (knock on wood). A code reader might still be a good idea to identify what was triggered.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
Re: (Johnr352)

Code reader is on the (long) shoppinglist <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> <p>Another quick question: Im replacing the brake discs and pads this weekend, along with a few other things. <br>What should I torque the bolts holding the caliper to?<p>Thats the only info i cant find on this forum.<p>Thanks <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #9 ·
Re: (petew)

Thanks. I've looked in there..but wasnt sure.<p>Is it this one <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0"> <p>Carrier plate <br>Stage 1 45 Nm <br>Stage 2 angle-tighten 50° <br>
 

·
Registered
Joined
·
4,272 Posts
Re: (blackvolvorules)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>blackvolvorules</b> »</i></TD></TR><TR><TD CLASS="quote">Turns out it was the KN-filter. The O2 sensor looked fine, so I tried putting the stock filter back in. After a couple of days the CEL went away.<p>I guess its bye-bye KN.</TD></TR></TABLE><p>I have heard of another person getting a CEL after they instaled the evolve intake. This make two instances where better breathing resulted in a CEL that I am aware of (I would guess that there are certainly more)<p>I have a K&N and no cel. interesting
 

·
Premium Member
Joined
·
2,600 Posts
Get the BSR code reader, it could easily be something else. I had the CEL after replacing my DP with the Phuz DP, but my CEL is totally unrelated to the DP, it's the EVAP system which is a common issue at my mileage, a software update is all thats needed for my problem.
 
1 - 11 of 11 Posts
Top