SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter · #1 ·
2004 V70 2.5T with 33000 miles. While moving from a stop, auto transmission occasionally slips as it shifts from 2d to 3d while in the 2000 RPM range. Engine RPM accels to 3000-3300 before slip stops and 3d is engaged. Slip lasts for approx .5 seconds. Problem just started at 32500 miles. Since it is an intermittent occurrence, I doubt my Volvo dealer will say I have a problem. Any ideas as to what the problem might be?
 

·
Registered
Joined
·
63,543 Posts
Re: V70 transmission problem (eagle2x)

Software upgrade required (warranty)
 

·
Registered
Joined
·
1,294 Posts
Re: V70 transmission problem (eagle2x)

I just went through the exact same thing. Software update did fix the problem.<p><A HREF="http://forums.swedespeed.com/zerothread?id=53994" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=53994</A>
 

·
Registered
Joined
·
99 Posts
Re: V70 transmission problem (eagle2x)

Yup, had same problem, Got software upgrade covered by warranty. I think the car runs better overall.....<p><br>-RS<br>2004 VOLVO V70 2.5T, loaded!!!
 

·
Registered
Joined
·
237 Posts
Discussion Starter · #5 ·
Re: V70 transmission problem (JRL)

JRL & others: Thanks for the advice. Today, my Volvo dealer downloaded two software upgrades, one for the transmission slip (2d to 3d) and second for an engine acceleration surge (45-90 MPH) at max throttle. First S/W upgrade was a TCM upgrade and latter was an ECM gasoline upgrade. My silver metallic V70 with sport & premium packages now flies quick and like new... hope these repairs sustain the current performance.<br>Repair codes on the warranty invoice sheet are listed as 30677036 and 30677021 respectively (in case that should be meaningful to anyone experiencing similar problems.)<p>I'm close to a purchase decision for a 2006 V50 T5 (loaded) as an addition to the 04 V70. Any opinions good or bad about the V50 would be welcome.
 

·
Registered
Joined
·
7,737 Posts
Did the same software upgrade today on our V70...wow, what a difference! Car has more pep and drives like new again!
 

·
Registered
Joined
·
908 Posts
Re: V70 transmission problem (eagle2x)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>eagle2x</b> »</i></TD></TR><TR><TD CLASS="quote">I'm close to a purchase decision for a 2006 V50 T5 (loaded) as an addition to the 04 V70. Any opinions good or bad about the V50 would be welcome.</TD></TR></TABLE><p>You should check out the S40/V50 forum...you'll find a lot of good info. Many of the S40/V50s have a few quirks but mine has been almost trouble free (certainly no major issues) and I would buy again. If I were looking for a small sport wagon, I would have no problem buying the V50. However, I'm not sure all 40-50 series owners would say the same thing. <p>Check out forum...more info than you can possibly imagine.<p>Good luck.
 

·
Registered
Joined
·
7,737 Posts
When I was having the tranny software upgrade today and the upper motor mount (the round one) replaced under warranty, I was given a '06 S40 with less than 250 miles on it to drive...wow, what a nice little car! I really enjoyed driving it and it was very peppy even though it was your basic car with no turbo....i2.1, I believe is what it's called. Looked under the hood and it was a 5 cylinder...very tight compartment! <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
63,543 Posts
Re: (MadeInJapan)

2.4
 

·
Registered
Joined
·
908 Posts
Re: (MadeInJapan)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>MadeInJapan</b> »</i></TD></TR><TR><TD CLASS="quote">I was given a '06 S40 with less than 250 miles on it to drive...wow, what a nice little car! I really enjoyed driving it and it was very peppy even though it was your basic car with no turbo....i2.1, I believe is what it's called. Looked under the hood and it was a 5 cylinder...very tight compartment! <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> </TD></TR></TABLE><p>I love my S40 2.4i - it does everything I need. It has enough get up and go and handles 70 mph+/- with relative ease. I've driven the turbos before and they are very nice and very quick but the NA engine is just fine. <p>Just my openly biased opinion...
 

·
Registered
Joined
·
7,737 Posts
my bad...yeah, 2.4i (I suppose the "i" is for "inline" engine?)
 
1 - 11 of 11 Posts
Top