SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Sunroof on my new to me V50 won't open.
Switch moves freely and I've opened it up (the switch) and it looks fine, no corrosion etc.
The siren works fine, normal volume and no messages about siren fault.
Theres no motor sound whatsoever.
Fuse looks fine too.

Any ideas on the cause?

I cleaned the sunroof drains needed a clean out after discovering a wet carpet on both sides after washing the car.
The sunroof scuttle does seem to take on a lot of water when washing the roof. Is that normal?

I noticed a grey connector that's not plugged in above the front interior light cluster although there's nothing to plug it into within the confines of its reach so maybe that's an option I don't have?

Sorry for all the questions I'm just very excited about my new purchase and want it tip top.
 

·
Registered
Joined
·
2,489 Posts
That grey plug is likely for a microphone accessory which I don't think any if the US cars had. If the battery had been disconnected and the reconnect procedure not followed, it could result in the sunroof and / or windows not functioning properly. Try disconnecting the battery for a least 10 minutes. Put the ignition key in position "II" and reconnect the battery. I had this happen to me along with ABS light on.
Good luck.
Stan
 

·
Super Moderator
Joined
·
9,305 Posts
Worth a try, but put the key in position II *before* disconnecting. Also, disconnect the ground side of the battery, safer and more reliable that way.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Wait what? Do I disconnect or reconnect the battery with the key in position II?

I've tried what was suggested in the second post followed by uem reset. No change
 

·
Super Moderator
Joined
·
9,305 Posts
If you've already disconnected the battery then never mind.

What exactly do you mean by uem reset? There is no UEM in this car, that's for the prev-gen S60/V70, XC90 etc.
 

·
Registered
Joined
·
2,489 Posts
No, the VIDA instructions say position 0 for disconnect and Position II for connect.
 

·
Registered
Joined
·
2,489 Posts
No, the VIDA instructions say position I for disconnect and Position II for connect.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
So what I did was take out key. Wait a few minutes then disconnect. Neg then pos. Waited 10 mins then reconnected pos then Neg. Is this right?
Didn't affect the sunroof anyhow.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
So what I did was take out key. Wait a few minutes then disconnect. Neg then pos. Waited 10 mins then reconnected pos then Neg. Is this right?
Didn't affect the sunroof anyhow.
 
1 - 9 of 9 Posts
Top