SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Sorry for my bad english but hope you can understand:p:p:p

Hi everyone,
sometimes When I turn the Key to position 1 , dashboard light On airbags signal On , it seems OK
but turn to position 2 , dashboard Signals won't On ,fuel gauge and temperature gauge have No reaction
Of course the engine can't start.

1.No warning messages shown.
2.New Battery.
3.it always happen with short time parking.
4.Car just running very well

Thank you everyone :D:D:D:D:D
 

·
Registered
Joined
·
2,725 Posts
Sorry for my bad english but hope you can understand:p:p:p

Hi everyone,
sometimes When I turn the Key to position 1 , dashboard light On airbags signal On , it seems OK
but turn to position 2 , dashboard Signals won't On ,fuel gauge and temperature gauge have No reaction
Of course the engine can't start.

1.No warning messages shown.
2.New Battery.
3.it always happen with short time parking.
4.Car just running very well

Thank you everyone :D:D:D:D:D
Check your batteries connections, while it may be new the connection terminals themselves may be dirty or loose.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7,272 Posts
We had a similar situation with our 850 and it turned out there was a kink/slight break in one of the terminal cables. This was probably preventing the battery from fully charging during short trips as it wasn't allowing the full current to pass, thus requiring longer trips to charge it to the point of having enough charge to start the car. Check your connections and cables!
 
1 - 3 of 3 Posts
Top