SwedeSpeed - Volvo Performance Forum banner

81 - 100 of 178 Posts

·
Registered
Joined
·
803 Posts
Discussion Starter #81
Been a bit so here's the latest.....

The steering rack replacement was an absolute PITA, I repeat PITA !!! But its complete and so far so good. Read a lot of people saying the reman racks end up being over assisted but this one feels stiff as it should be. Alignment shop did a great job and everything is dead on. Drivers side front frame rail and passenger side rear frame rail welded nuts that receive the sub frame bolts did actually break. Was able to blindly key them back to their original spot weld positions and torque the bolts down firmly. Crazy, this car has no rust ! Finished painting/clear coat on the wing. SC-901 lost speaker volume again. Fuses are good, unplugged, re plugged amp cable, wiggled all wires i could see on amp underneath pass seat and still no noise. Can't invest in a GROM till this is sorted. CEL for Large EVAP leak and potential CAT failure went away for 85 miles but then returned today. Gonna run Vida again tomorrow and will post AFR #'s. Both O2 sensors appear to be fairly new. Unless i tweaked the o2 cable snaking the steering rack in. And I did a bunch of other things that will be listed in my "wheeler Dealers" cost summary when all is sorted.
 

·
Registered
Joined
·
1,206 Posts
Could be either the head unit or the amp that's failing, let me know if you need either one. I have an under-seat amp and an SC-900 if you'd be willing to settle for that instead of a 901. Basically the same, just a slower CD changer and you can't use Pro Logic mode on FM.
 

·
Registered
Joined
·
15,507 Posts
Could be either the head unit or the amp that's failing, let me know if you need either one. I have an under-seat amp and an SC-900 if you'd be willing to settle for that instead of a 901. Basically the same, just a slower CD changer and you can't use Pro Logic mode on FM.
It's also missing the 5 band EQ and only has two fixed EQ curves rather than S70/V70/C70/S40/V40 (C70 is hidden; somehow the 901 knows whet it is connected to a C70)
 

·
Registered
Joined
·
1,206 Posts
It's also missing the 5 band EQ and only has two fixed EQ curves rather than S70/V70/C70/S40/V40 (C70 is hidden; somehow the 901 knows whet it is connected to a C70)
Shhhh... I'm trying to get rid of this thing lol.
 

·
Registered
Joined
·
803 Posts
Discussion Starter #85
Got the Wang installed, pretty happy with how it turned out. I used that two part 2K clear coat and it really made a difference VS the generic clear i used on the moondust front bumper. And "Chi-wagon" I relocated the R for you ! Ran a carfax and im owner # 4. Spent most its life in Colorado Springs and was maintained at Volvo Dealer till 186K. Report shows exhaust and motor mounts replaced at 180K. And transmission oil pan gasket ???? replaced twice . The only error I'm still getting in VIDA is for "short term fuel trim bank one upper limit". As you can see my idle fuel trim is negative 1.88%. It was negative 4% yesterday when i scanned. I haven't had a chance to smoke test yet, hoping to tomorrow. Does this look like Vacuum or intake leak ? Starts and accelerates fine.



 

·
Registered
Joined
·
803 Posts
Discussion Starter #86
Did a smoke test, the only place im leaking is at the base of the PTC. Considering there is just an oring there and its not hermetically sealed, Can i assume it would be normal to have some leakage there ?
 

·
Registered
Joined
·
15,507 Posts
your badges still look too high :confused:
 

·
Registered
Joined
·
803 Posts
Discussion Starter #88
C'mon Jared, with all your P80 knowledge you cant comment on the PTC leakage ? Improperly placed badges don't cause CEL's. Im kidding but at the same time really would like your guys help. Thats what were her for right ?
 

·
Registered
Joined
·
16,174 Posts
Did a smoke test, the only place im leaking is at the base of the PTC. Considering there is just an oring there and its not hermetically sealed, Can i assume it would be normal to have some leakage there ?
No it should seal pretty well. It’s not exactly an o ring, kind of a weird D shaped piece of rubber ish material. That actually can be replaced.
 

·
Registered
Joined
·
135 Posts
the badges are definitely too high. my "AWD" nearly lines up with the bottom of the license plate. strange.
 

·
Registered
Joined
·
15,507 Posts
yeah I wouldn't call a leak at the PTC normal
 

·
Registered
Joined
·
1,206 Posts
Badges are definitely too high. I think there's actually a diagram on VIDA with measurements on exactly where they should be placed. Back to the PTC leak... mine leaks there as well, but being pre-turbo I haven't done anything about it. The grommet for the PTC is replaceable, I don't have the PN handy but I replaced one on my '01 S60 when I had it. That had the worst one I've seen by far.
 

·
Registered
Joined
·
803 Posts
Discussion Starter #93
Appreciate you guys responding, just having a temporary episode of frustration when the car appears to operate as normal but throwing CEL. bmdubya, are you currently CEL free on your R ? Ooof, I don't think i want to relocate the badges at this point. Not sure whats up with the improper placement, carfax was clean regarding accidents. But may have been hit and fixed on the down low.
 

·
Registered
Joined
·
5,039 Posts
I'll skip any comments on the badges, and, unlike those who already commented, I don't have a clue about PTC, but will add something about the rubber trim along the bottom of the rear hatch window. Jared is right, and you can safely remove it to prevent rust from festering there, especially because you're planning on using this one as a winter runner. Keep up this pace, and you'll have a well sorted P80 in no time! :thumbup:
 

·
Registered
Joined
·
803 Posts
Discussion Starter #96
I'll skip any comments on the badges, and, unlike those who already commented, I don't have a clue about PTC, but will add something about the rubber trim along the bottom of the rear hatch window. Jared is right, and you can safely remove it to prevent rust from festering there, especially because you're planning on using this one as a winter runner. Keep up this pace, and you'll have a well sorted P80 in no time! :thumbup:
There is a tiny bit of rust developing by that rubber trim. So......just remove it and let it be ?
 

·
Registered
Joined
·
1,206 Posts
The CEL is on, but it's for an evap leak. Not gonna bother fixing that until I swap the delta link in, since the evap stuff will change anyway.

As far as the leaking PTC, my intake elbow is leaking right at the turbo inlet anyway, so I'll be ordering a Snabb intake soon. For some reason I keep buying more cars to distract me from fixing this one lol.
 

·
Registered
Joined
·
803 Posts
Discussion Starter #98
So when i removed the elbow to inspect the PTC better i thought the clamp to turbo was too easy to unscrew. When it refitted it, the gear or slots on the clamp had become stripped and couldn't be tightened up very snug. I replaced the clamp and got it good and tight. Did a little cruising this AM and threw on my generic code reader, to my surprise it was emissions ready and no pending codes. Then ran VIDA and got the beautiful display off all greens ! So i guess enough air was escaping at that connection to affect my fuel trims. I'm amazed that pipe didn't pop off during boost. So she's all good ! (for now). Back to cosmetics.

 

·
Registered
Joined
·
5,039 Posts
There is a tiny bit of rust developing by that rubber trim. So......just remove it and let it be ?
Definitely, pull the trim off to prevent that from getting worse. If it's just a few small spots on the surface, cleaning and touch up paint might be enough. If it's spreading behind it, you could probably tape off a straight line, clean out the area, and rattle can a similar looking black and it wouldn't look bad. At least, that's what I would start with before it gets bad.
 
81 - 100 of 178 Posts
Top