SwedeSpeed - Volvo Performance Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
so i was in bumper to bumper traffic today and all of a sudden, my car just shut down and turned off, so i was like wtf?!<p>so i put it back into park, turn the key to the off position, and turned it back on, the car started again but with some SERIOUS hesitation. and it was back to bumper to bumper traffic, when the traffic cleared, and i stepped on the gas to get some speed, i noticed that there was a loss of power. The tach would go all the way to 5, 6, 7000RPM just to accelerate, and it wasn't even a fast acceleration. It was really slow. So, my first thought was oh no, my turbo blew out (2001 volvo v70 2.4T w/ 95k miles is what i have), but if my turbo blew out, wouldn't i technically not be able to even drive as the exhaust gases pass through the turbo and if the turbo seized, wouldn't it just back the gases up and not be able to esacpe? So my next thought was the TCV....I remember looking at the IPD one bc they said that cars of normally have faulty or broken TCV all the time, so I thought that might be it. oh, and the sparkplugs are brand new too, replaced no more than 1-2k miles ago with oem plugs<p>Also, i noticed that when i took my foot off the accelerator, there was a hard jerk. like you could really feel that the engine was jerking back into it's neutral spot when you weren't stepping on the gas. I don't really know how to describe it other than a hard jerk when i took my foot off the gas. <p>But in any case, can anyone help me out and ID what's going on? If i have to go to the dealer, or if it's just a faulty TCV? PLease!!!<p>Thanks in advance!<br>-Tim<br><BR><BR>
<i>Modified by timwu12 at 6:48 PM 4-3-2009</i>
 

·
Registered
Joined
·
2,486 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (timwu12)

Where you at? I could read your codes (I'm in PQ).
 

·
Registered
Joined
·
63,543 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (timwu12)

ETM, go to your dealer, free replacement (10 yr 200K warranty)
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #4 ·
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (Mika)

Hey Mika!<p>I'm a UCSD student so I live off of UCSD by UTC mall. I would REALLY appreciate you doing that!
 

·
Registered
Joined
·
2,486 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (timwu12)

If you want to swing by my work tomorrow in Sorrento Valley, I'll give it a try. <br>I PM'd you with my cell phone number.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #6 ·
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (Mika)

Is it weird that all of a sudden, everything is back to normal? I've read on other posts that this is what happens. Meaning it stalls like once a week, but then during the other times, it seems like nothing's the problem.<p>Is there a bigger underlying problem if this is the case?
 

·
Registered
Joined
·
4,019 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (timwu12)

google search swedespeed for etm & stalling or failure, there are lots of posts. Here's a good summary:<p><A HREF="http://forums.swedespeed.com/zerothread?id=108277" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=108277</A> "...4. When the throttle actually starts “failing,” you’ll feel a significant jerking motion as the engine tries to stall, often at highway speeds. Stepping on the accelerator pedal will, momentarily, do nothing."<br>
 

·
Registered
Joined
·
2,486 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (MrTippy)

for the curious amongst you, it was a triple-whammy: ETM, MAF and coolant temp sensor.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #9 ·
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (Mika)

Hey!<p>Thanks so much again for the help! I really appreciate it!<p>Anyways, I had a couple questions:<p>1. What was that site that you use to buy your parts from again? something like myswedishparts.com or something?<p>2. I got to thinking, what's the probability that all 3 could've gone wrong at the same time. Could there be like an even bigger underlying problem? Like a messed up ECU or something?<BR><BR>
<i>Modified by timwu12 at 2:12 PM 4-10-2009</i>
 

·
Registered
Joined
·
2,486 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (timwu12)

They probably did not fail at the same time. The codes have been there for a while most likely. The ETM dies eventually no matter what. The MAF and the other sensor codes can be caused by frayed wiring or oxidized connectors.<p>Some good sites to buy parts are myswedishparts.com, fcpgroton.com, ipdusa.com.<BR><BR>
<i>Modified by Mika at 12:38 PM 4-7-2009</i>
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
so guys, i took it to the dealer, they told me this:<p>1. MAF---which is what we saw<br>2. broken radiator?!----wth?! they said there's a hole in the radiator tank and it needs to be replaced-- ~$900<p>-nothing about a thermostat sensor problem or throttle body sensor.<p>so, does that make sense to you guys?
 

·
Registered
Joined
·
2,486 Posts
Re: (timwu12)

It's possible the radiator is leaking, but that's inconsequential to the symptoms. I did not smell any coolant, have you notice the car is losing coolant?<p>I think they first want to blame the MAF until they do anything with the ETM as I mentioned to you. <br>
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #13 ·
THat's the funny thing, I've never seen any leaking coolant. I looked, and the reservoir is still at the full mark.<p>As for the ETM, I thought it would be weird that they didn't mention it, especially after we scanned for it. But I guess that's typical. They want you to pay instead of them paying.
 

·
Registered
Joined
·
533 Posts
Re: URGENT!!! car stopped in the middle of traffic, and lost power---please help! (Mika)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Mika</b> »</i></TD></TR><TR><TD CLASS="quote">for the curious amongst you, it was a triple-whammy: ETM, MAF and coolant temp sensor.</TD></TR></TABLE><p>+1 for you man. this is why SS is awesome.
 

·
Registered
Joined
·
2,486 Posts
Re: (timwu12)

tim, I got a spare MAF that's not perfect but it will not give a code. You can try it for a while if you like. We can erase the codes and I can take a look at that radiator too. The ETM code will come back if the ETM is kaput so no worries about that.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #16 ·
that would be great!! Wow, I can't believe you offered to do that! That's EXTREMELY nice of you! When would you like to meet up? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"><BR><BR>
<i>Modified by timwu12 at 1:37 PM 4-10-2009</i>
 
1 - 18 of 18 Posts
Top