SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Good evening,

I'm looking to upgrade a few parts and looking for advice. Here is some of my background this car is my daily driver I do 35k both ways to work, some traffic some highway so I enjoy the peace and quiet but also enjoy spirited driving what do you think of the following has anyone tried these upgrades? Currently the only upgrade I have on my Rdesign is the factory Polestar tune.

1- Elevate engine torque mount(After replacing stock engine torque mount I still have a loud bang when doing fast gear change from 1st to 2nd around 5500RPM) has anyone experience this?
2-Debating between iPd or Elevate rear anti sway bar, any suggestions?
3- Elevate performance sport exhaust (I would like my car to be a bit louder under hard acceleration but not on highway would this work?)

Also looking at a few exterior changes, silver bulbs for the rear, (again iPd or Elevate?) and front head light bulbs to have a blueish tint...

One last question anyone tried to change the interior green lighting to blue? how hard is this?

all upgrades will only be done after the warranty is over in December
Thanks for your help
Claude
 

·
Super Moderator
Joined
·
15,179 Posts
Welcome to the forum Claude!

I would go with the eFocus torque mount. It's $40 from TascaParts.com and will last longer than the Elevate mount. The Elevate mount is great, but the lifespan wasn't (at least for my driving style).

The iPd bar makes a bit of a difference, but the Elevate bar makes the biggest difference. Also look at some of the options for the Focus ST and Mazda 3. I have the Elevate bar and love it.

The Elevate exhaust makes a great sound both with an upgraded downpipe and the stock downpipe. If you plan on keeping the stock downpipe, the Elevate exhaust should be exactly what you're looking for. However, you'll see better gains (even with a P* tune) from replacing the downpipe as well. But there will be a bit of drone on the highway with a 3" DP and Elevate's 3" catback. I don't find the drone to be bad, but I'm not sure how sensitive you may be to the noise.

Chromed turn signal bulbs can be purchased just about anywhere. I got a pack for 4 off ebay for $10 shipped.

You cannot change the screen, gauges, etc. lighting without some serious tearing apart and soldering of LEDs. You can change your dome lights and footwell lights to LEDs, I have blue LEDs in the footwells and the rest are white. One member did successfully strip the green film off of the gauges so they now illuminate white. You could put any color film backing to change the color, but the process is extremely involved and complicated. Especially since you'll be taking the gauges apart and removing the needles.

Be sure to pop over to C30Crew.com as well. Lots of activity for the C30 over there. Around SwedeSpeed, you'll find most of your help in the S40/V50 section.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the information, greatly appreciated. The E Focus is that because it comes from the Electric Focus (part-CM5Z-6068A) does this add any vibration into the car? Did it stop the awful bang coming from under the hood?

By the way, I`ve been following your project online Wow amazing you are one passionate guy (crazy in a good sense). Won`t be changing the LEDs for sure... I`ll go on C30Crew also...
 

·
Super Moderator
Joined
·
15,179 Posts
The e focus adds very minimal vibration. The Elevate mount will add quite a bit of vibration. And yes, it's from the electric focus.

What's the bang you're getting? That doesn't sound right... Unless your motor mount is completely shot and you have metal hitting metal. Are your side engine mounts in good condition still? Does it only occur when changing gears, or just when coming on/off the gas?

Thanks for the compliments! I have fun with my cars. :)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
The Bang is when doing fast gear change from 1st to 2nd around 5500RPM, the noise seems to be coming from the passenger side floor. Originally I thought it was the torque mount so Volvo accepted to replace it for free but it did not fixe the problem. When I change gear (1st to 2nd around 5500RPM) you feel a bit of wheel spin then a big bang, like if the motor is hitting the firewall. Can`t see anything wrong inside the engine compartment. any ideas?
 

·
Super Moderator
Joined
·
15,179 Posts
Just reading on S40 could it be my upper right engine mount?
That's what I'm thinking now... Worth a check! That's always the first of the two mounts to fail. Went out on mine a few months ago, engine had room to shift up to 1 inch! Definitely made some unpleasant noises until I replaced it.
 
1 - 7 of 7 Posts
Top