SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
The following problem began developing about a week ago. When using the right turn signal (and only the right), 1) the flash rate is about twice that of normal, 2) the little orange hazard triangle warning light in the middle of the dash comes on, and 3) a message appears in the lower left corner that reads "Bulb Failure Right Turn Sign." Normally I would take this a face value and assume I have a burned out bulb, however the problem is not continuous. It only happens about every other time I use the signal. Plus I checked the external bulbs when it was acting up and they all were flashing, although quite rapidly. Has anyone else experienced this? If it was hardware related, I would think it would be either a constant problem or one that occurs on both sides. <IMG SRC="http://www.swedespeed.com/ubb/confused.gif"><P>I'm taking the car in next Friday hoping that it will act up for the Dealer, but it will probably work just fine for him!<P>White T5, 7800 miles, DOB 3/00, Mobil 1, FID 540, 616 and 642.
 

·
Registered
Joined
·
3,706 Posts
You might go ahead and try replacing the right side bulbs for the turn signals. Somtimes these bulbs have manufacturing flaws, that I have actually seen before. Sometimes the soldered contacts on the back of the bulbs "flakes" off. I know for sure, a rapid turn signal means a defective bulb.<P>-Drew
 

·
Registered
Joined
·
528 Posts
Dunno...the solenoid that makes the thing blink could be the culprit too.<P>On my 1966 Volvo P1800 I had to replace the solenoid once a year because my signals would speed up. I never replaced the bulbs.<P>One would hope things had changed in the past 35 years, but you never know...<P>- Darell
 

·
Registered
Joined
·
528 Posts
You'd think so, huh? It will totally depend on how the thing is wired (and us mere consumers may never know). It may very well be that there is a seperate solenoid for each side. Nothing would surprise me about these cars anymore, though I can't figure out why they'd want to do that. Remember that this car requires a $120 software download to activate the trailer wiring harness, so anything is possible.<P>I do agree with Drew that it is most likely an intermittent bulb failure. If the resistance is suddenly too high (or would it be too low? - I'd have to scratch my head for a second, and I don't have time <IMG SRC="http://www.swedespeed.com/ubb/smile.gif"> the flash rate would increase dramatically.<P>Most likely it's a defective bulb in there somewhere, but you never know....<P>- Darell<P>Of course, I can't figure out why the V70 engineers think think I'd like to be in 4th gear at 20mph, either, so what do I know?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
Well, I hope its just a bulb. But since the dealership has highly trained bulb changers that will find the problem for free, I'll still take it in next Friday. I'll let you know what thay say.<BR>
 

·
Registered
Joined
·
528 Posts
Heck yeah...I would. Well, actually, I don't think I've ever gone in for just one single problem. In fact, my July visit list is now five items long.<P>If I didn't go in once a month they'd probably forget my name, and that would be a shame. They know how I like my coffee now.<P>- Darell
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #8 ·
Well, I took it in Friday. The good news is that they found the problem. A faulty bulb socket (shorted internally). The bad news, they don't stock the part so it's been ordered and I get to go back again for yet another visit.
 
1 - 9 of 9 Posts
Top