SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
Hi, I've just finished my tuning stage 3 with Hilton as details below

Tuning software with Hilton Stage 3

Add-Ons: Automatic Transmission Torque Limiter Removal – Remove the first and second gear torque limiter from automatic transmissions.
Catalyst Delete (Stage 2 and up only)
E85 Tuning

But I have problem with my boost level. I just get MAX PSI only 13. But I want to get about 25 PSI / 1.7 Bar of boost refer to Hilton's mention

I check no any vaaccum leak. Still looking around the root cuase.

I use MAMBA Westgate with K24 Hybrid

https://youtu.be/qeHwZUZ6LPM

Is there any experiences from anyone?
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #2 · (Edited)
Hi, After check log with Hilton. He said the symptom come from the injector does not work as expected & the throttle is not fully wide open.

I got the engine light blink when I fully pull pedal third gear at 4.5 rpm.

I got the code 1100 throttle body issue also.

So I will look at the shop to test & clean the injector and I brought repair kit ETM contactless sensor to fix the problem.
 

·
Registered
Joined
·
83 Posts
It would be interesting to see the final results. Keep us posted 🙂
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #4 · (Edited)
Yeah , Today I just bring my new 650 CC Injector out. For readiness check before going to test with the professional. Is there anyone can see which one is broke?

<img src="https://i.ibb.co/8BjRh73/IMG-2620.jpg" alt="IMG-2620" border="0" width="500" height="400"/>

<img src="https://i.ibb.co/cXtXswB/IMG-2618.jpg" alt="IMG-2618" border="0" width="500" height="400" />

It seems like the first one is broke?

<img src="https://i.ibb.co/6ydmhz8/Full-Size-Render.jpg" alt="Full-Size-Render" border="0" width="500" height="600"/>
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #5 · (Edited)
It would be interesting to see the final results. Keep us posted 🙂
Look at my Vida result so many error

<img src="https://i.ibb.co/FmhJwKJ/IMG-2573.jpg" alt="IMG-2573" border="0" width="500" height="600"/>

<img src="https://i.ibb.co/jgjsqyD/IMG-2574.jpg" alt="IMG-2574" border="0" width="500" height="600" />

Test ETM Result

<img src="https://i.ibb.co/5vdB397/IMG-2575.jpg" alt="IMG-2575" border="0" width="500" height="600"/>
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #6 ·

·
Registered
Joined
·
133 Posts
Discussion Starter · #7 ·
Update Info. I ask dead time of my injector from seller and send to Hilton to investigate.

<a href="https://ibb.co/RCcJ685"><img src="https://i.ibb.co/55LJjZ7/650cc-Dead-Time.jpg" alt="650cc-Dead-Time" border="0" /></a>
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #8 · (Edited)
What i am trying to do next is.

1. Change spring on Mamba Westgate to another color (It might be grey or black)

<img src="https://i.ibb.co/QMSRM6R/Mamba-Springjpg.jpg" alt="Mamba-Springjpg" border="0">

2. Swap TCV form original Pierburg to HD TCV from S60Rrace but Hilton recommend to use the original is better.

<img src="https://i.ibb.co/S56BLDL/TCV-Race-S60-R.jpg" alt="TCV-Race-S60-R" border="0">

3. Swap to custom intake manifold to more flow to the engine

4. Set Methenol to inject at current MAX 13 PSI
 

·
Registered
Joined
·
62 Posts
If your Ignition coils are bad. Even 1 will have such a bad misfire that the ecu will not allow more boost and cut ignition. You will see fluctuating boost and feel it too. Vibration.
You will even hear the sound of the engine change.
Mine was only noticeable under full load. 100% pedal.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #10 · (Edited)
If your Ignition coils are bad. Even 1 will have such a bad misfire that the ecu will not allow more boost and cut ignition. You will see fluctuating boost and feel it too. Vibration.
You will even hear the sound of the engine change.
Mine was only noticeable under full load. 100% pedal.
Yeah, I change everything New Coil Set , Iridium include change fuel system to return fuel system with regulator boost reference 1-to-1 ratio. and waiting for Hilton re-tune again. Let's see what happen

<img src="https://i.ibb.co/kcFQqb3/27118.jpg" alt="27118" border="0">

<img src="https://i.ibb.co/5Y35MBq/LINE-P20190721-20261618.jpg" alt="LINE-P20190721-20261618" border="0">
 

·
Registered
Joined
·
296 Posts
Hilton is extremely knowledgeable. Follow his advice. You will also want to gap your
iridiums down as well or you'll probably see a misfire at high boost. Once you are pushing
in the 20+ psi range gap them to .024 Be very careful when gapping iridiums as you
can very easily damage the ground strap or electrode. Buck performance sells a tool
specific to this task and comes with feeler gauges.
 

·
Registered
Joined
·
296 Posts
You'll likely want 1 step cooler plugs as well. If you plan on beating on it...
2 steps colder. Just remember that if you go 2 steps colder and don't get the plugs
nice and hot on a regular basis you'll cold foul the plugs sooner. If you are an occasional
heavy foot driver, "spirited" then 1 step colder will suffice.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #13 · (Edited)
You'll likely want 1 step cooler plugs as well. If you plan on beating on it...
2 steps colder. Just remember that if you go 2 steps colder and don't get the plugs
nice and hot on a regular basis you'll cold foul the plugs sooner. If you are an occasional
heavy foot driver, "spirited" then 1 step colder will suffice.
Thanks for your suggestion but I am waiting to re-tune first. Then I can try again. Let's see I will see the problem like you mention or not. But before I made decision to go for Fuel Return System because I have fuel run out at high RPM with just only 16 PSI. I have to fix this first then I can see more problem after I go beyond 20+ PSI.

<img src="https://i.ibb.co/dMFZrbY/IMG-3317.jpg" alt="IMG-3317" border="0"width="500" height="600">
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #14 · (Edited)
If your Ignition coils are bad. Even 1 will have such a bad misfire that the ecu will not allow more boost and cut ignition. You will see fluctuating boost and feel it too. Vibration.
You will even hear the sound of the engine change.
Mine was only noticeable under full load. 100% pedal.
I have the issue about engine misfire a few days ago. I think it's about coil failure that cause misfire. I hit the full load pedal 100% then the engine start fluctuation. I am looking solution to solve this issue. I think the cheap coil pack that I brought from Ebay is not work

<img src="https://i.ibb.co/q0p0dgy/1565483099847.jpg" alt="1565483099847" border="0" />
 

·
Registered
Joined
·
296 Posts
Try gapping your plugs to .024


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
306 Posts
Move the coil to another cylinder and give it another pull. If the misfire moves, replace coil..if not replace the spark plug.

Injector code should be addressed as well.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #17 · (Edited)
Move the coil to another cylinder and give it another pull. If the misfire moves, replace coil..if not replace the spark plug.

Injector code should be addressed as well.
I move injector connector from #2 to #3. then it work but when the morning come. It happen again. I got the injector signal missing change from #3 to #2. Any idea about this.

The suspect issue

1 ECU Failure. I fix some parts
<img src="https://i.ibb.co/VYvfg03/ECU.png" alt="ECU" border="0">
2 Injector wiring Harness Failure. (I change it before)
3 Spark Plug & Coil. I think it should not be the issue because sometimes it's work after I swap the fuel injector connector from #3 to #2
4 Injector Failure. Should not be.
 

·
Registered
Joined
·
296 Posts
Camshaft positioning sensors and or solenoids.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #19 ·
Camshaft positioning sensors and or solenoids.


Sent from my iPhone using Tapatalk Pro
It seems like nothing bad but only injector adapter does not fit tight at injector #3. After make it fit then the signal missing at injector has gone.

<img src="https://i.ibb.co/kKJDd2M/LINE-P2019821-171313.jpg" alt="LINE-P2019821-171313" border="0">
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #20 · (Edited)
1ST Test Run Hilton Tune Stage 3 with Fuel Return System Tune

<p>
</p>
 
1 - 20 of 31 Posts
Top