SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #1 ·
I replaced the broken trip odometer reset button over the weekend, and since I have had no odometer or trip odometer. Then this afternoon, the odometer and trip odometer started working, but would stop when the trip odometer would hit 9/10 of a mile. I have looked over the gears, and they all have their teeth. It must be an electrical problem, but I am not sure what. Any suggestions would be most appreciated. Thank you
 

·
Registered
Joined
·
636 Posts
Scirocco,

Ya dont suppose we could mod that OD with a digital unit out of a V60 do ya?

I have thought about this for the last four days and cant think of anything except a corroded ground from your cluster to your chassis some where. Any thoughts?
 

·
Registered
Joined
·
177 Posts
Re: Trip Odometer works to 9/10 of a mile-then stops (1sciroccofahrer)

it's actually probably not electrical. rather there is some gear that is not engaging properly (reset button not fully pulled out of something) or there is something that is prohibiting the odo from turning.

If your speedo works the electrical functions are working fine.
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #4 ·
Re: Trip Odometer works to 9/10 of a mile-then stops (rs4-380)

I drove the car to the gym this morning, and low and behold it worked. I drove 10 miles, and there were absolutely no issues with the trip odometer, or speedometer. I will keep an eye on it in the coming days, and report back. Thanks ever so much VolvoGuy and rs4-380
 
1 - 8 of 8 Posts
Top