SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
alright so I have an issue. My s70 has no ets light on but I'm having very hard shifting. I also have issues when speeding up from 1k rpms when it hits 2k it tries to shift causing continuous shifting which is quite obnoxious. Could anyone tell me what the culprit is? I've also cleaned the damn ETM more times than I can count and have seen the ets light on at some points but it eventually turned off. No CEL at the moment either. Any help would be appreciated. Is this a failing transmission or a bad ETM?

Sent from my HTC6500LVW using Tapatalk
 

·
Registered
Joined
·
63,543 Posts
Your continued ETM cleaning does not help at all, once properly
It would help to mention the YEAR and model of your Volvo and the mileage. No info, no help!
If this is a 2000 non turbo with the 5 speed I would be inclined to say transmission
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #4 ·
Woops sorry 2000 s70 GLT 2.4l 121,XXX miles

Sent from my HTC6500LVW using Tapatalk
 

·
Registered
Joined
·
6,563 Posts
Have you looked at the BCM? It could be the ETM. Buy a yellow label one and swap it.
 

·
Registered
Joined
·
63,543 Posts
If you ever saw the ETS light you attack that problem first. I don't care if it turned back off, it flashed, and that's enough for me.
Original white label? Get another one. You cleaning has not helped, probably hurt it. time for a new, used or XeMODeX throttle.
Don't listen about the BCM, that's not your problem.
It would help to pull the hidden, stored codes (VIDA)
 
1 - 8 of 8 Posts
Top