SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have recently purchased a 2004 S60 AWD 2.5T and have been having trouble with traction control kicking in randomly in conditions it would never activate in (aka dry pavement). It kicks in often when the car is going 20 or under, causing it to loose power, pull all over the road at times, as well as cause the speedometer to drop and not read correctly. The intervals at which this occurs are anywhere between 5-15 seconds. The ABS light is on, along with the message "anti-skid service required". The ABS light goes on and off, but is generally on most of the time. A mechanic friend of mine ran a scanner on the vehicle, and he determined there was a mechanical fault for the left front. This being the case, I replaced the wheel bearing, as well as the CV shaft on the front left of the car, speculating that the bearing or the tone ring were causing the issue. After the fixes, the problem still persisted. Does anyone have any ideas as to what my issue could be? I am at a complete loss here.
 

·
Registered
Joined
·
515 Posts
May be caused by a few things, the abs light may be there because of a faulty abs sensor (may try replacing them with a used one from the junkyard, only never pull on the wire, always pop the sensor with a flat screw driver from underneath). The skid message may be from a cracked reluctor ring, loose axle center bolt, faulty steering angle sensor, faulty DEM module (corroded, google up, xemodex can fix these), CEM water ingress. Multiple possibilities, try google up with the word 'forum' in the searched, there are many topics about these issues
 

·
Registered
Joined
·
2,038 Posts
Typically the steering angle sensor. I need to replace mine but they’re over $300 new.


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top