SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 48 Posts

·
Registered
Joined
·
398 Posts
Discussion Starter #1
Went to the body shop today. Shop said not to repaint the whole car; they can do the hood and the roof and polish out the paint on the sides (said sides were in very good shape). Estimate was $2,000.
 

Attachments

·
Registered
Joined
·
15,472 Posts
subsciribed!
 

·
Registered
Joined
·
398 Posts
Discussion Starter #3 (Edited)
subsciribed!
I have a list of mechanical items that I have to get to before the paint. Still waiting for the PCV parts from IPD. On a brighter note, UPS just showed up with my tweeters for the rear panels.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #4
I also bought the rear spoiler on eBay before I even found the car! Figured I could just prime it and sell it and make a little profit if I couldn't find a car.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #5
The Propus wheels on the car all have curb marks on them, so I am going to use these wheels for now. These were on my V70 T5.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #6
Pictures of car in current state.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #7 (Edited)
Replaced the front and rear speakers in the doors. Previous owner made the adapter for the rear speakers. Head unit has to go.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #8
USPS dropped off the rear spoiler brackets today from Germany. Took three weeks for them to arrive at a cost of $135.00. I guess you have to pay to play.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #10
My PCV replacement parts finally shipped, so I will start on that as soon as it arrives. The next thing on the list is replacing suspension parts. I started the car two days ago and put it in drive and heard a slight whirring sound coming from the transmission. It does it under load in the drive gears so I am going to do a transmission service. I'm trying to decide if it warrants doing a manual swap since I have a lead on all of the parts.
 

·
Registered
Joined
·
15,477 Posts
Nice! I am subscribed as well. The propus Cs are nice but gotta be impossible to keep clean. I like the 5 spokes.
When paint shop does work they'll do the wang and install?
 

·
Registered
Joined
·
398 Posts
Discussion Starter #12 (Edited)
Nice! I am subscribed as well. The propus Cs are nice but gotta be impossible to keep clean. I like the 5 spokes.
When paint shop does work they'll do the wang and install?
The Propus wheels have a lot of curb marks on all of them, so getting them refinished is out of the question. I will have the paint shop paint the wang, but I will put it on. I think the 5 spokes are slightly wider than the Propus wheels. I have 225x45x17 tires on them and they did fit well on the old V70 (these were refinished so there are no marks on them).
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #13
Had a little more time today. Head unit came in last night so decided to install. Only problem is I can't find a way through the firewall to run power for my amp in the rear for the sub. Didn't want to drill through so I was looking for a grommet in the firewall.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #15

·
Registered
Joined
·
15,472 Posts
Thanks! I saw that tube but didn't know that it was a pass-thru. I guess I'm wiring up the subwoofer tomorrow.
Yeah just pop that weird looking knobby plug out. It's kinda tricky to run smaller wires though on their own so you may need to push rope or something stiffer through first if your wires are too small to push trough politely.
 

·
Registered
Joined
·
398 Posts
Discussion Starter #17 (Edited)
I found the pass-thru on the firewall. I had to mount the amp in the corner because it wouldn't fit under the deck like it did in my V70. Sounds so much better now.
** EDIT ** Just figured out why it wouldn't fit under the deck. This car has a full size spare and my V70 had a donut. Guess I'll relocate the amp when I get a new spare.
 

Attachments

·
Registered
Joined
·
398 Posts
Discussion Starter #18 (Edited)
Well, I got the PCV kit and installed it today. As usual (with my luck), I put it all back together, started the car and got 4 codes:


P1310 - Igniter Circuit Malfunction No. 3
P0305 - Cylinder 5 Misfire Detected
P1507 - Idle control system malfunction
P1505 - Idle Air Control System At Adaptive Clip


I cleared the codes and restarted the car and let it run and now I get two codes - P1310 and P0305. The car won't hold an idle and when I hold the RPM's at 1500 for a while, the engine will accelerate, run smooth but won't hold an idle. I also pulled the injector rail off again and made sure everything was seated correctly. Also checked plug number 5 to make sure it was seated also. Is it time for me to buy a Toyota?
 

Attachments

·
Registered
Joined
·
707 Posts
Did you manage to unplug the coolant temp sensor and forget to plug it back in?

Sounds like you missed a connector or something.
 

·
Registered
Joined
·
398 Posts
Discussion Starter #20
Did you manage to unplug the coolant temp sensor and forget to plug it back in?

Sounds like you missed a connector or something.
Didn't unplug the temp sensor, just removed the hose for more room. I was going to flush the coolant and change the heater core if everything had gone okay. I went back and checked to make sure the idle air control valve and throttle body sensor were connected to make sure I didn't miss anything. Also had to recheck the fuel pressure regulator vacuum line.
 
1 - 20 of 48 Posts
Top