SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10,097 Posts
Discussion Starter · #1 ·
Car gave a fault message, engine not warming up fast enough...

Never noticed anything from the meter, weather is cold for the last 3 or so months with temps mostly around 32 degree.

Last Friday the code was read from the car. After that I payed a bit more attention to the meter and I noticed that when driving slower (...) the needle was just before mid indicator, not more than one mm. When driving a bit more spirited the needle was exactly in the middle.

After replacing the thermostat it showed that a small "bearing ball" thingy in the thermostat was missing..
 

·
Registered
Joined
·
1,648 Posts
Re: Thermostat replaced (Johann)

Quote, originally posted by Johann »
Car gave a fault message, engine not warming up fast enough...

Never noticed anything from the meter, weather is cold for the last 3 or so months with temps mostly around 32 degree.

Last Friday the code was read from the car. After that I payed a bit more attention to the meter and I noticed that when driving slower (...) the needle was just before mid indicator, not more than one mm. When driving a bit more spirited the needle was exactly in the middle.

After replacing the thermostat it showed that a small "bearing ball" thingy in the thermostat was missing..

I hate these 'idiot gauges' most manufacturers saddle us with. The temperature dials on most cars pretty much have three positions. Cold, Ok, and Hot, with a fairly huge temperature range reading OK (meaning pegged to the center of the gauge). Apparently keeps people from obsessing about it and making unnecessary service calls.
 

·
Registered
Joined
·
470 Posts
Re: Thermostat replaced (Johann)

Quote, originally posted by Johann »


After replacing the thermostat it showed that a small "bearing ball" thingy in the thermostat was missing..

And where did that little ball bearing go? On its way to the water pump impellar? (or worse?)
I hope not!
 

·
Registered
Joined
·
1,814 Posts
Re: Thermostat replaced (pino)

Interesting, my check engine light came on yesterday. After a night in the service department, they found a faulty thermostat. They replaced it, lubed my clutch pedal, and installed my cup holder.
 

·
Registered
Joined
·
10,097 Posts
Discussion Starter · #5 ·
Re: Thermostat replaced (pino)

Quote, originally posted by pino »


And where did that little ball bearing go? On its way to the water pump impellar? (or worse?)
I hope not!

It was sitting in a corner of the thermostat housing.

I never received any messages on the dash btw.
 

·
Registered
Joined
·
2,964 Posts
Re: Thermostat replaced (Johann)

So the fault was detected when you read out the ECU, and not the dash?
 

·
Registered
Joined
·
10,097 Posts
Discussion Starter · #7 ·
Re: Thermostat replaced (Short Circuit)

Yes. Last friday the car was in for a service and to fit the iPD sway bars. This is when they saw the fault code and ordered the parts needed.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top