SwedeSpeed - Volvo Performance Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Well I sold my 2002 v70 (The Ammo Can) to get an AWD model. I was so amazed at the performance of the 2wd P2 offroad, that i needed the bigger, better brother.

The Ammo can: https://www.matthewsvolvosite.com/forums/viewtopic.php?f=9&t=88754&hilit=ammo+can



The new car:
2002 Volvo XC70 2.4 T
165k miles


The Goal:
Overland capable rig for long offroad trails/camping


I picked up this car for $500 about 1hr away from me. The previous owner took decent care of it for 8 years with synthetic oil changes.

Immediate attention needed:
transmission fluid flush
oil change
Strut tops seperated (never seen that before)
Gauge cluster dead
vibration at idle
oil cap seal 7.jpg 20190327_120934-2016x1134.jpg 20190327_121003-2016x1134.jpg
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #2 ·
Got the tranny fluid changed. It was just about all black.

-The way I do these is to remove the Lower cooler fitting from the radiator and slide a rubber hose over it into a drain pan.
-Run the engine for a few seconds until you see bubbles coming out of the hose.
-Then pour the fluid into a container and measure the exact amount that came out (between 2.5-3qrts).
-Put that amount back into the tranny dipstick tube, and then do this over until the fluid it shiny and red! (about 15 Qts)

I used Valvoline MaxLife here, I know there is some controversy behind that.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
Next up is the Gauge cluster. This is the easiest cluster repair you can do, I have done several board repairs in this manner. Here are some pics of the re flow See the points circled, and reflow those solder joints. They are VERY tiny be careful. 20190327_105237-2016x1134.jpg 9.jpg 7 (1).jpg 20190327_110406-1134x2016.jpg 20190327_111149-2016x1134.jpg
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 · (Edited)
PCV system cleaned out, and replaced some bits, its would not pass the "glove test"

20190409_110533.jpg
20190409_110536.jpg

You can see here that I replaced the hard plastic line with double walled fuel line. it may last, it may not. Cleaned out the banjo bolts well and all other hard lines

20190409_110538.jpg

No pics, but i did clean the stock injectors and replace the filter baskets, O-rings, and caps.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 · (Edited)
I did a 24hr piston soak with marvel mystery oil to help clean it up, and I'm also running some AutoRX for 3k miles. Just trying to get it a little cleaner inside before we start the MODS!!! I have another 1500 miles to go before we start tuning. In the mean time, deleted the resonator and muffler. I will re do it all later with 3 inch pipe.

20190507_130554.jpg
20190507_175549-2016x1134.jpg
20190507_193517.jpg
20190515_104453-2016x1134.jpg

 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
How much boost should i be getting all stock? Put on a gauge on today, and it is steady at only 2.5PSI under WOT. It will jump to 5psi for a split second when up shifting at WOT. Need to get my baseline stuff taken care of before my Hilton tune is ready.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
Well..... the ECU fried itself last night. Worked with Rob trying to get it working, but the ECU just didn't want to be tuned I guess. It blew an internal fuse.

He is sending me a new ECU this next week luckily. Awesome service for sure.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #8 ·
Got the Hilton stage 2 loaded in, having some issues with boost staying steady. Did six 0-60mph pulls, with 2 of them being good. My boost levels seem to kind of wander around. They will stay under 5psi, and then it's like the tune kicks in for a second or so up to 11psi with awesome power. I may start with a new tcv and CBV kit. Going to send Rob my videos and see what he things.

One of my good pulls was a full second faster than my best 0-60 on stock tune.
 

·
Registered
Joined
·
1,180 Posts
I have Hilton stage 1, new stock 14T turbo and Snabb 3" downpipe w/ cat. Catback is a new original Volvo. In 3-5 gears I'm getting 11 psi spikes and 10 psi for prolonged runs (can't really push it for a long time, 120 mph is still the ECU limit). First 2 gears have a torque limit, like 240 Nm (180 lbft) that you can pay Robert to remove.

2002 has viscous coupler vs Haldex in 2003+, I think. Most likely VC is dead, the fluid inside it does not last long.
 

·
Registered
Joined
·
1,246 Posts
Got the Hilton stage 2 loaded in, having some issues with boost staying steady. Did six 0-60mph pulls, with 2 of them being good. My boost levels seem to kind of wander around. They will stay under 5psi, and then it's like the tune kicks in for a second or so up to 11psi with awesome power. I may start with a new tcv and CBV kit. Going to send Rob my videos and see what he things.

One of my good pulls was a full second faster than my best 0-60 on stock tune.
Check out the TCV, pierburg sells a replacement for like 20 bucks from a porsche on rockauto
Also check the vacuum lines, usually a leak or two somewhere if not serviced in years
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #11 ·
I'm going to order a new Pierburg TCV and the upgraded CBV kit from IPD today. Seems like the best place to start since these wear out anyway. After that, i'll check the duty dycle of the injectors.

As a part of my stage 2 tune, I had the torque limiter removed.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #12 ·
New TCV from FCPEuro fixed my boost issues. This car is a rocket now with the stage 2 Hilton tune. I'll post new 0-60 times soon along with raw log Data in an excel spreadsheet

Here is a video on how to access and asjust the wastgate:
 
1 - 14 of 14 Posts
Top