SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1 (Edited)
Hi everyone!!
This past weekend, I took my beloved daily driveR to Lime Rock Park, located in Lime Rock, CT for their first ever, winter autocross. Tempted to see what my VR can do, I took it to the track to put my caR to it's paces. Needless to say, it was a blast to drive in the snow and all of the instructors praised me calling me the "drift king".. haha

I even made it on their facebook cover photo!

<div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-post" data-href="https://www.facebook.com/limerockpark/photos/a.10150621612034003.398616.44115954002/10152870379264003/?type=1" data-width="466"><div class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/limerockpark/photos/a.10150621612034003.398616.44115954002/10152870379264003/?type=1">Post</a> by <a href="https://www.facebook.com/limerockpark">Lime Rock Park: The Road Racing Center of the East</a>.</div></div>


Some more rolling shots:

<div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-post" data-href="https://www.facebook.com/limerockpark/photos/a.84709764002.81001.44115954002/10152870393389003/?type=1" data-width="466"><div class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/limerockpark/photos/a.84709764002.81001.44115954002/10152870393389003/?type=1">Post</a> by <a href="https://www.facebook.com/limerockpark">Lime Rock Park: The Road Racing Center of the East</a>.</div></div>


<div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-post" data-href="https://www.facebook.com/manicpixels/photos/a.320104564832119.1073741828.319175201591722/396998847142690/?type=1" data-width="466"><div class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/manicpixels/photos/a.320104564832119.1073741828.319175201591722/396998847142690/?type=1">Post</a> by <a href="https://www.facebook.com/manicpixels">Manic Pixels</a>.</div></div>


<div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-post" data-href="https://www.facebook.com/manicpixels/photos/a.397321043777137.1073741829.319175201591722/397321670443741/?type=1" data-width="466"><div class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/manicpixels/photos/a.397321043777137.1073741829.319175201591722/397321670443741/?type=1">Post</a> by <a href="https://www.facebook.com/manicpixels">Manic Pixels</a>.</div></div>



Anyways, I'm driving back home no problem and park her for the night (saturday). Monday rolls around and I get a few messages that are all too common around here...

anti-skid, chassis settings, brake failure stop safely...



Like anyone would recommend here on this forum, I had to check the codes via VIDA...



:eek::eek::eek::thumbdown::thumbdown:


I know my struts are going soon, but to rule the majority out, I wanted to see what was permanent. I erased all the codes. There was a couple that stuck (see above figure highlighted). CEM-1A64 and CEM-9C03

Searching high and low in the forum, I have come to the conclusion that I may have to:
1.)check the pressure sensor (inspect/clean/re-install)
2.)check the Haldex feed pump to see if it's working (there's a write up here to put 12V to see if it works)
3.)replace the DEM and send it to either xemodex or BBA inc.


I'm 99.9% confident that may fix the permanent code CEM-1A64. If I am wrong, please let me know!! The other code highlighted (CEM-9C03), I have no fricken idea what that is. I've checked here on the forum and did a google search to no avail.




Any inputs?
 

·
Registered
Joined
·
1,100 Posts
Nice photos. I think I may have the same antenna ring code. My key light (the one that is around the ignition key hole does not light up. I think I need to replace my light. Have a look and see what yours does. As far a the AWD codes, I'm not very well versed in that... yet.
 

·
Registered
Joined
·
482 Posts
Nice action pics! Theres a recent aoc pump message thread with details on fix. maybe 3-400 in parts, driveshaft removal. Basically when any one of the awd modules or sensors quits then awd is off. If it's the aoc pump you'll need parts 30783079 + 30787687, it's not uncommon failure on all p2 awd.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Still have functioning AWD?
I wish. When the car is up to temp, I mashed the gas in 1st gear and the tires spin.

Nice photos. I think I may have the same antenna ring code. My key light (the one that is around the ignition key hole does not light up. I think I need to replace my light. Have a look and see what yours does. As far a the AWD codes, I'm not very well versed in that... yet.
Learn from my mistakes!

Nice action pics! Theres a recent aoc pump message thread with details on fix. maybe 3-400 in parts, driveshaft removal. Basically when any one of the awd modules or sensors quits then awd is off. If it's the aoc pump you'll need parts 30783079 + 30787687, it's not uncommon failure on all p2 awd.
I was planning on buying a 40K complete haldex aoc with DEM from one of our members here for $250 w/o shipping. I'm going to replace the pressure sensors too. Sound like a good idea?
 

·
Registered
Joined
·
1,242 Posts
I'd be checking connections and grounds. Don't go throwing parts at it without checking some basics first.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
1,605 Posts
If the AWD is intermittent I would first check the temp/pressure sensor. Actually I would check that first anyway because it's super cheap and easy to replace.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
If the AWD is intermittent I would first check the temp/pressure sensor. Actually I would check that first anyway because it's super cheap and easy to replace.
AWD is off completely. I'll look into the pressure sensor and take it from there.
 

·
Registered
Joined
·
8,608 Posts
since you don't have this code in combination with BCM-0094 the DEM doesn't sound like it is dead yet, but it may be forthcoming. I'm betting pressure sensor, but you need to test voltage to the pump too.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
since you don't have this code in combination with BCM-0094 the DEM doesn't sound like it is dead yet, but it may be forthcoming. I'm betting pressure sensor, but you need to test voltage to the pump too.
12V to pump and while I'm there, for sure, I will replace that sensor.
 

·
Registered
Joined
·
2,651 Posts
If the AWD is intermittent I would first check the temp/pressure sensor. Actually I would check that first anyway because it's super cheap and easy to replace.
THIS.

When my AWD went after playing in the snow, I took it to MB Auto after the dealership quoted me 1500+ for the repair.

Mike fixed it for under $200, replaced just the temp/pressure sensor.

That was the first time I ever used him, and he has been "my guy" ever since.
 

·
Registered
Joined
·
11,927 Posts
I'd be checking connections and grounds. Don't go throwing parts at it without checking some basics first.

Sent from my SM-G900V using Tapatalk
This. The CEM can't talk to the DEM, that's why you get a CEM code. It's a data connection issue.
Any actual DEM pump/sensor issues should throw a DEM code.
 

·
Registered
Joined
·
8,608 Posts
This. The CEM can't talk to the DEM, that's why you get a CEM code. It's a data connection issue.
Any actual DEM pump/sensor issues should throw a DEM code.
pump and sensor would through a DEM code, but no communication to DEM is a dead DEM.
 

·
Registered
Joined
·
8,608 Posts
what about the ones where the pump overcurrents and blows the fuse, causing the lack of DEM communication?
so check the fuses but I doubt that's it.
 

·
Registered
Joined
·
2,651 Posts
Any actual DEM pump/sensor issues should throw a DEM code
Negative. I had NO codes. Just no AWD.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #17
Crap. I just wasted $118. Just installed the pressure sensor and CEM-1A64 still remained present, even after clearing the code.
 

·
Registered
Joined
·
572 Posts
Without looking at the counters on some of the codes, they could be very dated and irrelevant. For certain you've got some issues with either the shocks or the wiring too them. Also, without seeing any counters, I would say you've got BCM that is taking out the high side of the network. I'm especially curious to see when the CEM DF13 and 16 stored and if it's conjunction with any of the communication errors between modules. Those codes indicate an open somewhere in the network.

Did you read any of the fault tracing for the codes you posted?
 

·
Registered
Joined
·
482 Posts
http://www.matthewsvolvosite.com/forums/viewtopic.php?f=10&t=23703
^cem 1a64 thread

I think 1a64 means communication with either aoc pump or dem module but the DTC's dont always communicate what is going on. If dem module is bad that means either corroded pcb from age/ water ingress or xemodex warns a bad aoc pump can smoke the dem even if brand new. Also could be yaw sensor under the passenger seat, steering sensor or abs related but the only code that stuck 4u was the 1a64. Also might want to check fr axle bolts just in case... gl
 
1 - 20 of 39 Posts
Top