SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
2006 XC70
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi All,

I just had my the Four-C shocks on my 2006 XC70 replaced with regular shocks my local garage. However, when I got the car back. the "Text Window" on my dash ( the one that shows warning messages ) was dark. Turning it off and on shows a brief glimmer of a green bar for a moment, but no text shows. The Four-C shocks that were removed still have the wires on them, so they were disconnected at the connectors where the wire from the base of the shock is connected (~ 15 inches up). I don't currently have a VIDA DICE to check codes. The local garage seems to have no idea what happened.

I've had researched the Four-c delete on this and other forums prior to the replacement and I was expecting some error messages to be displayed because of the wiring not be terminated with the solenoids/resistors, but I was not expecting the Information screen to be blank/off.

Any guidance would be greatly appreciated. Thanks. PGM.
 

·
Registered
Joined
·
1,033 Posts
Take the old shocks and just plug them in to see if it goes back to normal. May be that something unrelated happened.
 

·
Registered
2006 XC70
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks J5T, very sensible suggestion. I'll give that a try.

Update, after a couple of days driving the car (5 or 6 restarts), the Text Window "magically" came back on. However, it's behavior is intermittent...sometimes it comes on and others it does not. I am wondering if there is something like a ECU diagnostic that runs on start up that might be affecting its behavior. In any case, I will monitor the behavior. I might look at trying to do a delete of the Four-c software configuration and see if that changes thing...I believe I saw that it can be done with VDASH.
 
1 - 3 of 3 Posts
Top