SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hello all,

Have an issue with my '04 V70 T5, 115k. A week back I got a CEL and using my basic Scantech engine tool I was able to scan the vehicle and received a p0128 code. I also received a 'low coolant level' warning on the dash's message center. I cleared the code and checked the coolant level in the reservoir. The coolant was near the 'min' so I added a little bit of Volvo coolant to the reservoir.

This past week the temperature gauge in the dash has gone haywire. It goes from not reading at all, up to the mid point, back to not reading, to reading an 1/8, etc... The CEL has stayed off, my coolant level is good. The vehicle blows hot air.

What could be the culprit for the temperature gauge to act wonky? Bad coolant sensor? Bad thermostat? The new air freshener in the trunk (lol)?

Thanks in advance for any suggestions or troubleshooting tips.
 

·
Registered
Joined
·
4,007 Posts
sounds like the t stat. but when you add more coolant there might be air bubbles and that might be what's causing your coolant temp gauge to move up to normal and back down again. it should go away soon. other wise the t stat is stuck open.
 

·
Registered
Joined
·
278 Posts
I have a similar issue with my 01 V70 T5. Recently it does not get to operating temp (more like a 1/4 of the way up as opposed to the normal 1/2 way point). Was also thinking t stat stuck open? Also, how often should the coolant be changed out (I think it has been a 3 years at least). Old coolant probably would not explain the running too cool though. Any idea on cost I should expect to have the thermostat changed out? I have done them in other cars and know it is easy enough - I just will not have time to do it anytime soon. Any help appreciated.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
Temp gauge is now not moving, and the heater is only blowing warm air inside. If I get a new t-stat can I just replace the t-stat, or do I have to get the whole housing with the sensor?
 
1 - 4 of 4 Posts
Top