SwedeSpeed - Volvo Performance Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I have an '06 S60R. I just noticed my temp gauge is not working. The car feels sluggish under accelleration too. Anyone have similar problems? Any ideas?
 

·
Registered
Joined
·
4,248 Posts
IIRC there is a TNN out for that need to pull codes with a volvo reader but i bet it needs a ECM upgrade
 

·
Registered
Joined
·
21,166 Posts
Software upgrade should cure the issue.
 

·
Registered
Joined
·
21,166 Posts
It's as if the ECM thinks the engine is cold forcing it to burn rich.
We've alerady told you, go to the dealer for a software update. This was a problem with the 06's and there are several threads on the topic.
 

·
Registered
Joined
·
1,480 Posts
This was a problem with the 06's and there are several threads on the topic.
Amazing there are still Rs running around without the upgrade.
 

·
Registered
Joined
·
2,841 Posts
Happened to me 3 (4?) times. A few software upgrades and a new thermostat and I haven't had any problems since.
 

·
Registered
Joined
·
16,954 Posts
Plane on ECT / Thermstate first and then software upgrade.

The car wil go into limp mode if the ECT goes bad.

I have seen it on numerous cars.
 

·
Registered
Joined
·
18 Posts
Has anyone seen this same problem on a 2007 S60R AWD? Mine just started doing the exact same thing, no reading on temp gauge, cooling fan running full out even with a cold engine, poor acceleration, but no Check Engine light.

- Mark
 

·
Registered
Joined
·
11,936 Posts
There have been many cases of this here where a simple ECU RESET restored correct operation. My car was one of those cases.
 

·
Registered
Joined
·
35 Posts
just had this happen with my 06 VR a month or so ago - software update + new thermostat fixed it.
 

·
Registered
Joined
·
1,555 Posts
How sluggish are we talking about? Like, "that's a bit slower than I remembered" or "wow, there's something SERIOUSLY wrong here."
 

·
Registered
Joined
·
199 Posts

·
Registered
Joined
·
16,954 Posts
I would replace the Thermostat and rest the ecu ........
 

·
Registered
Joined
·
11,936 Posts
How sluggish are we talking about? Like, "that's a bit slower than I remembered" or "wow, there's something SERIOUSLY wrong here."
It will boost but not nearly as much. Power really falls off above 3000 RPM. It's driveable though. I'd say you could do 0-60 in maybe 11-12 seconds.

I'm on my 2nd ECU reset to "cure" this same problem. Will probably take it to the dealer next time it happens assuming it's before my CPO runs out (at 91K now).
 
1 - 19 of 19 Posts
Top