SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,521 Posts
Discussion Starter · #1 ·
In April, my TEM was deactivated for no reason that I can figure out. I bought the car (2015.5 V60) in November of 2018 and got a year of Volvo On Call service and a access to the Volvo App. This all worked great until it didn't. When it stopped working I contacted Volvo US and they gave me a set of steps to try to restart the TEM, but said if it didn't work that the dealership would have to do it. They said the outage was in the Volvo side of things. Today I took the car in to have the oil changed and the dealership told me it would be $250 to reset the TEM.

I contacted Volvo US and they said the only reason the TEM would be deactivated was if I had ended a subscription, but they can clearly see that I haven't done that and still have three months of service left.

Anyone had a similar problem? If so, what were you charged by the dealership? $250 to solve a problem I didn't cause doesn't sit well with me.
 

·
Registered
Joined
·
824 Posts
I had the same problem, but I lucked out because the the dealer reset my TEM for free and Volvo US gave me another year of Volvo On Call for free.

The reason I got it for free is because I had just left my car at the dealer for a couple weeks for an engine replacement. They figured that since it was sitting with the battery disconnected for a while, that is what messed up the TEM. They were wrong because Volvo On Call worked flawlessly for about 5 days after I got my car back. Then it stopped working all of a sudden for no reason. But since they thought it was their fault and weren't going to charge me, I had no interest in arguing with them. Sadly, like you, I have no idea why my TEM quit and needed a reset. I did get the same initial diagnosis from the Volvo US people. They claimed my TEM must have deactivated because my subscription was up. Unlike you, however, I had to prove to them it wasn't.

$250 seems steep. It didn't take them a full hour to reset mine.
 

·
Registered
Joined
·
1,521 Posts
Discussion Starter · #3 ·
They tried to reset mine and told me that they had to do a software update to make it work. I also asked them to balance the wheels and they told me I would need new tires as mine were cupping. I called bull****, asked them to show me and they said that it was just starting and couldn't be seen, it had to be felt. The tires have 8000 miles in them. The dealer installed them when I bought the car. They also overcharged me for an oil change and brake flush. Both services have prices shown on their website and but when I got the receipt each service was $25 more than shown. Interestingly, I used a $50 off coupon that they had sent me. My reaction to all of this was not good. I would be surprised if I'm even allowed back in the building. The service counter is close to the showroom which had customers in it. I wasn't shy with my assessment of the situation,particularly the fact that they marked up the services in order to recoup the $50 coupon.

Maybe Volvo US will come through for me.
 
1 - 3 of 3 Posts
Top