SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7,275 Posts
Discussion Starter · #1 · (Edited)
TCV issue? Anyone with VIDA?

Hey guys-

So last week I had to install a new TCV as I suspected mine had crapped out (sudden loss of power, no turbo, but no stalling or sputtering and no lights). I simply got an OEM unit since I'm not tuned at all.

Install went fine, I know I put the lines on the correct ports as I did one line at a time (old off, new on). Now, after 5 days of driving, 2 of which were 4 hour drives, the car seems to be acting slightly "different."

My power is back, the car pulls strong, but when I'm cruising at higher speeds, the car seems to almost surge ever so slightly when under load. Say I'm at 75 mph, going up a hill, cruise locked in. The revs stay consistent at ~2300, the car maintains speed just fine, but I feel a slight hesitation every now and then as if the turbo kicked in to maintain speed, but then kicks out then back in. Am I just not used to the normal feel of the turbo since my TCV had been slowly dying?

I don't have a boost gauge so I can't see what it's doing for numbers. I followed ipd's HD TCV learn process after I installed it, so I was wondering if anyone with VADIS could see if Volvo had a specific learning procedure that I should have done instead.

Thanks for your insight.
 

·
Registered
Joined
·
2,014 Posts
I don't think you need any special learning process as you replaced one stock component with another.

How does it behave under WOT?
 

·
Registered
Joined
·
1,866 Posts
You'll need Vida for the V50... The last Volvo to be added to Vadis was the S40 I (Mister Bishi base).
 

·
Registered
Joined
·
7,275 Posts
Discussion Starter · #4 ·
I don't think you need any special learning process as you replaced one stock component with another.

How does it behave under WOT?
Seems to perform fine. I feel a slight vibration but I know one of my wheels is slightly out of balance.

You'll need Vida for the V50... The last Volvo to be added to Vadis was the S40 I (Mister Bishi base).
Oh got ya. VIDA, VADIS, all the same to me. Basically, anyone with Vida to check?
 

·
Registered
Joined
·
3,256 Posts
Hey Vee. no specific learning process needed to perform. the computer will "learn/adapt" on it's own over a bit of time. when i did mine it was ~5 days.
the IPD process is supposed to speed up the learn curve....
 

·
Registered
Joined
·
7,275 Posts
Discussion Starter · #6 ·
Hey Slasher thanks for looking into it. I guess I'll drive for another few days and see what happens. Again, maybe I'm just not used to the increased turbo feel compared to the 88K old TCV which most likely wasn't performing well.
 
1 - 6 of 6 Posts
Top