SwedeSpeed - Volvo Performance Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
6,608 Posts
Discussion Starter · #1 ·
So this morning the R decided to randomly throw a "Reduced engine performance" message that went away as quickly as it showed up while coasting downhill. Scanned it with VIDA and there are no codes. So I decided to do some datalogging to see if I could get the issue to come back. I couldn't but I found something interesting. At 5500RPM the car is only making 1700hpa of boost with the atmospheric pressure being 970hpa. That's 10PSI. Should my TCV dutycycle be at 100% at WOT?

I'll do it again and get a graph... Stupidly closed mine.
 

·
Registered
Joined
·
1,587 Posts
Is the car tuned? VIDA duty cycle is only what the ECM sends out to the solenoid. If the TCV is old/worn or there is a leak for instance the boost pressure will be lower.
 

·
Registered
Joined
·
6,608 Posts
Discussion Starter · #6 ·
Here's a graph I got.

 

·
Registered
Joined
·
6,608 Posts
Discussion Starter · #7 ·
And of course now the numbers look better now that they're saved :mad:
 

·
Registered
Joined
·
1,587 Posts
What gear is that and whats the ambient temp?
 

·
Registered
Joined
·
6,608 Posts
Discussion Starter · #9 ·
2nd and OAT is 70F
 

·
Registered
Joined
·
1,587 Posts
Second gear is too short to build boost. Revs go up too fast. Not enough load. Try third better. Or go up a steep hill

IAT? Thats quite low. I just assume that at this temp there isnt more boost needed to produce required torque. Cause thats how this ECU operates
 

·
Registered
Joined
·
6,608 Posts
Discussion Starter · #11 ·
Second gear is too short to build boost. Revs go up too fast. Not enough load. Try third better. Or go up a steep hill

IAT? Thats quite low. I just assume that at this temp there isnt more boost needed to produce required torque. Cause thats how this ECU operates
No, that's outside, I didn't log IAT.

I guess I have to find a spot to use 3rd...
 

·
Premium Member
Joined
·
3,745 Posts
I thought the duty cycle for the TCV was the percentage of time it's closed. So at 100%, that would mean you're not bleeding off any boost pressure.*

So at WOT, and not yet at target boost, I think 100% duty cycle is normal.

*I'm probably wrong.
 

·
Registered
Joined
·
1,587 Posts
Actually it doesnt allow 100% DC. Max is 99.6% thats just the way ECM software is built. And iirc looking at different files. Stock tune shouldn't see 100% no matter what.
 

·
Registered
Joined
·
1,587 Posts
You were logging TCV duty cycle just when it happened? Wow
 

·
Premium Member
Joined
·
3,745 Posts
It was stored on the ECU and looked at by a tuner.

Edit: I should clarify, it was showing that the TCV had hit 100% duty cycle on occasions. Considering my car would boost to 25+psi, I think that was true.

Moral of the story: Don't use an aftermarket solenoid for a TCV.
 

·
Registered
Joined
·
1,597 Posts
I agree 100 percent about not using an aftermarket tcv and if you start having boost issues out of no where and are all of a sudden over boosting then under boosting its usually the tcv. I just changed out an ard hd tcv that was maybe a yr and a half old. I in my stock pierburgh type tcv and car ran like a champ again.
 
1 - 18 of 18 Posts
Top