SwedeSpeed - Volvo Performance Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
920 Posts
Discussion Starter · #1 ·
Hey guys, I just picked up a fantastic CY T-5R example today and it has a strange HVAC issue. I did a bit of searching and couldn’t find anyone with a similar issue.

First time I started the car I turned it on and the fan would blow on high, and hot air, regardless of what position the fan speed switch/temp dials are in. So I turned it off, and back on, this time the fan speed started off slow but gradually increased to high, regardless of my inputs.

There are no AC or REC lights at all. The ECC panel basically does nothing. I inspected the fuses and the both looked fine, ended up pulling #5 just to get home without boiling to death.

Does this seem like a bad ECC panel and not the other culprits (resistor, temp sensors, etc)?
 

·
Registered
Joined
·
6,228 Posts
"Oh, I'm worried about a blower fan that won't turn off."

[Casually drops that he bought a Gul into the 850 thread.]

Pics or a Camry, sir!
 

·
Registered
Joined
·
14,016 Posts
Congrats on the new gul - I love mine.

Sorry, don't know the answer to your question but I'd probably start by replacing the ECC panel with one from the junkyard to see if that does anything.

Please post some pics when you get a chance!
 

·
Registered
Joined
·
920 Posts
Discussion Starter · #5 ·
Glad to hear you personal stuff was addressed and you were able to get a car <img src="http://www.vwvortex.com/Anthony/Smilies/wink.gif" border="0" alt="" title="Wink" class="inlineimg" />

You will likely need to replace the blower motor fan and resistor.
Yes sir, thank you! Got all my ducks in a row and then this example showed up less than 2 hours from me while I was home/in-between work trips. Glad to be part of this club.

So we're thinking blower, resistor, and ECC panel - one vote for each. Would the blower need replacing of it's operating? It seems like there's not control over it.

She's currently residing in a garage in PA while I work out logistics to get her to NJ.
I'll try to upload from my mobile and see if it works...
 

Attachments

·
Registered
Joined
·
920 Posts
Discussion Starter · #7 ·
What headlights are those? Very shiny.
Super shiny. They were listed in the ad as "Jewel headlights" and I'll be honest didn't really scrutinize the backs when I was under the hood. Maybe Depo? They have HIDs aimed super low as to not blind people. That's something to be addressed.
 

·
Registered
Joined
·
1,026 Posts
Car looks very nice, congratulations. Tasteful mods too. I see a shiny exhaust :0) Black plastic trim looks nice too.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
17,037 Posts
Swap the ECU. That's sounds like a corrupt bin issue.
This thing has a speedtuning ECU or something goofy right? Regardless of whether it's the problem you should dump that asap. Take it Steve and have him put a real tune on that thing.

Those headlights are ABMs.
 

·
Registered
Joined
·
920 Posts
Discussion Starter · #11 ·
This thing has a speedtuning ECU or something goofy right? Regardless of whether it's the problem you should dump that asap. Take it Steve and have him put a real tune on that thing.

Those headlights are ABMs.
Sending you a PM, Jared.
 

·
Registered
Joined
·
17,037 Posts
1 - 13 of 13 Posts
Top