SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
2016 XC90 T6 Momentum Plus
Joined
·
76 Posts
Discussion Starter · #1 ·
Driving home last night on a major Interstate at the posted 65 MPG, my XC90 w/ 240K miles suddenly lost power (though not entirely) and began vibrating. The Check Engine light illuminated, began flashing, and after about 30 seconds, went off, though neither the performance nor vibration stopped.

The car struggled on inclines, improved on decent, and I found that using the manual shifting mode, I could downshift, raise the RPMs to around the 3,000 RPM rate and gain some torque while maintaining posted speed.

The Check Engine light re-illuminated several times, but also extinguished itself shortly thereafter, often blinking, not steadily lit.

Given the hour of the night I elected to limp home on what seemed like 4 out of 5 cylinders.

I've never experienced a sudden change in performance while driving at speed with this car, and have no idea the cause.

Hoping you have some advice. Thanks.
 

·
Registered
Joined
·
1,999 Posts
Sounds like a bad ignition coil.
 

·
Super Moderator
Joined
·
9,305 Posts
A blinking check-engine means a "miss" is detected. Most likely cause is bad gas. Second most likely is a bad coil pack. Two bottles of isopropyl dry gas for the former, trip to the shop for the latter.
 

·
Registered
2016 XC90 T6 Momentum Plus
Joined
·
76 Posts
Discussion Starter · #4 ·
Replaced all the coils and still the problem persists. Limped over to the shop where compression in cylinder 2 was quite low. Scoped and found a burnt exhaust valve. Not good.


Sent from my iPad using Tapatalk
 
1 - 4 of 4 Posts
Top