SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 55 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
When I accelerate from 60-80 mph, and the rpms increase from approx 2300 to 3600, my caR has started stumbling/sputtering until I back off the accelerator. It's almost like a slipping sensation, or coughing feel, and it doesn't do it under other conditions like lower speeds or slower acceleration.

Any ideas what I should ask about the next time it's in the shop?

Thanks,
 

·
Registered
Joined
·
2,192 Posts
Have you updated the software at the dealer? I had this issue and did some research, turns out it was a software issue and after I had Volvo update it I haven't had it since.
 

·
Registered
Joined
·
2,545 Posts
I would have the ECU codes read, there's likely some there (even without a CEL). Sounds like maybe the fuel pressure sensor (FPS) is going bad.
 

·
Registered
Joined
·
31 Posts
Am experiencing a similar problem. For me, it occurs between 2500 and 3000 rpm, especially noticeable when I am in 5th or 6th and I try to accelerate. As rpms build, there is a brief but very noticeable dead spot where the engine hesitates, then continues to accelerate. Does not seem to happen in lower gears, but maybe that's just because the rpms build much more quickly and the engine does not have a chance to hiccup.
Just had my 82.5K service completed at dealer, they said they found no ECU codes and therefore do not know what might be causing the issue.
At 75K, I was experiencing a similar issue (noticeable while accelerating in lower gears), but there was a MAF error code and I had the MAF replaced (under extended warranty).
Thanks in advance for appropriate insights/guidance.
R Driver
 

·
Registered
Joined
·
21,166 Posts
fuel pressure sensor?
 

·
Registered
Joined
·
2,141 Posts
I would start with the cheapest option, fuel filter, and suggest getting a ScanGuage. I am having a fuel issue too, but I think some sediment got stirred up and is intermittently blocking fuel flow through the filter. Gonna swap filters today since it is such an easy job.

Sent from my SGH-T999 using Tapatalk 2
 

·
Registered
Joined
·
1,028 Posts
Join the club. To repair this issue I have tried so far (this year):

new spark plugs
new ignition coils (ipd hd R)
new fuel pressure sensor
new manifold absolute pressure sensor
cleaned throttle body
replaced positive crankcase vent box/pipes/hoses
cleaned fuel injectors and fuel rail
new fuel filter
new air filter

The problem persists unchanged. However the engine now idles beautifully and when not sputtering sound good otherwise.
 

·
Registered
Joined
·
2,141 Posts
Join the club. To repair this issue I have tried so far (this year):

new spark plugs
new ignition coils (ipd hd R)
new fuel pressure sensor
new manifold absolute pressure sensor
cleaned throttle body
replaced positive crankcase vent box/pipes/hoses
cleaned fuel injectors and fuel rail
new fuel filter
new air filter

The problem persists unchanged. However the engine now idles beautifully and when not sputtering sound good otherwise.
Yeah, but did you shread your angle gear like I did?

Sent from my SGH-T999 using Tapatalk 2
 

·
Registered
Joined
·
1,028 Posts

·
Registered
Joined
·
2,192 Posts
Join the club. To repair this issue I have tried so far (this year):

new spark plugs
new ignition coils (ipd hd R)
new fuel pressure sensor
new manifold absolute pressure sensor
cleaned throttle body
replaced positive crankcase vent box/pipes/hoses
cleaned fuel injectors and fuel rail
new fuel filter
new air filter

The problem persists unchanged. However the engine now idles beautifully and when not sputtering sound good otherwise.
...but did you update the software?

The 3000rpm stumble is a known issue that is directly related to a software problem in 04 R's, the problem is magnified with a tune. Volvo came out with a software update in January 2004 to fix this issue but most dealers will NOT upgrade your car's software without specifically being told to do so, which is why my dealer serviced 04 R that I bought in February of 2012 still didn't have this update done to it.

Oh and it fixed the stumble, so I would strongly suggest taking it to the dealer and having them update the software.
 

·
Registered
Joined
·
1,028 Posts
Dang, thanks Stefan,

That really pisses me off. I've asked my dealer about this multiple times over the years. They have blamed it on PCV Breather Box being dirty (which is why I did the service and write-up), or "all those aftermarket parts" (flailing their arms, literally).

Do you remember any search terms for locating the discussion about this software update? I'd like to bring the TNN to my dealer.
 

·
Registered
Joined
·
2,192 Posts
Dang, thanks Stefan,

That really pisses me off. I've asked my dealer about this multiple times over the years. They have blamed it on PCV Breather Box being dirty (which is why I did the service and write-up), or "all those aftermarket parts" (flailing their arms, literally).

Do you remember any search terms for locating the discussion about this software update? I'd like to bring the TNN to my dealer.
Would this be of any help? http://forums.swedespeed.com/showthread.php?110482-3000-RPM-Stutter-Help
 

·
Registered
Joined
·
1,028 Posts

·
Registered
Joined
·
2,192 Posts
Yeh, that helps. Will visit dealer again.
Going through old posts now looking for anything. Currently reading:
http://forums.swedespeed.com/showthread.php?118952-Shudder-stutter-under-boost-(not-only-WOT)

Starting to wonder here if having never followed ECU Adaptive Learning protocol is cause of me having stutter.
Or that my wastegate setting is factory 7psi instead of 4.5 psi like other 04's.
I doubt it, a 7psi wastegate isn't far enough out of the norm to throw off the ECU under moderate acceleration.
 

·
Registered
Joined
·
195 Posts
...but did you update the software?

The 3000rpm stumble is a known issue that is directly related to a software problem in 04 R's, the problem is magnified with a tune. Volvo came out with a software update in January 2004 to fix this issue but most dealers will NOT upgrade your car's software without specifically being told to do so, which is why my dealer serviced 04 R that I bought in February of 2012 still didn't have this update done to it.

Oh and it fixed the stumble, so I would strongly suggest taking it to the dealer and having them update the software.
Why is it magnified with a tune? My car works fine with stage 1 or 2 but when I load stage 3 I have stuttering when crusing at highway at ~65mph. And thats when I hold the throttle steady and when using cruise control. Havnt noticed any stuttering when accelerating. Last time I had my car at a service they told me it was upgraded, both engine and gearbox.

Is this still the same problem with software you are talking about?
 

·
Registered
Joined
·
1,028 Posts
I'm still reading old posts (as far back as the lively ones in 2004).

First there is a software update as mentioned.
Then also, regardless of the update, the condition can happen with a bad coil. In one case, a bad spark plug caused a bad coil.
In many cases it manifested itself first with people having the BSR tune.
In most cases, regardless of tune, this was temperature related. People in warmer climes got the condition quickest.
FMIC helped some of these people, but was not a cure-all.
Discussed as being related was CVVT, cam sensors,(still reading that discussion, don't yet know the conclusion reached if any) engine oil type, coils.
Discussed by many then and now as being changed but NOT curing the problem was FPS, MAP/IAT, TCV, MAF, PEM, TB cleaning, ECU cooling, Stock vs Tuned, Spark Plugs.
 

·
Registered
Joined
·
2,141 Posts

·
Registered
Joined
·
2,141 Posts
Why is it magnified with a tune? My car works fine with stage 1 or 2 but when I load stage 3 I have stuttering when crusing at highway at ~65mph. And thats when I hold the throttle steady and when using cruise control. Havnt noticed any stuttering when accelerating. Last time I had my car at a service they told me it was upgraded, both engine and gearbox.

Is this still the same problem with software you are talking about?
Do you have an upgraded TCV?

Sent from my SGH-T999 using Tapatalk 2
 

·
Registered
Joined
·
31 Posts
I hear ya re: a software update for 04s...guess I should start the quest of replacing miscellaneous parts on my 06.
 

·
Registered
Joined
·
195 Posts
Do you have an upgraded TCV?

Sent from my SGH-T999 using Tapatalk 2
Not yet, but I have a brand new Volvo OEM. But new IPD version 2 is on the way. Also new HD coils, silicone hoses, injection cleaner, maybe thats the solution.

Already cleaned MAF, replaced FPS, MAP/IAT (Boost Pressure Sensor), TCV, temperature sensor in the waterpump housing, dont know what its called (”ECS” – Engine Coolant Sensor?), fuel filter, air filter, spark plugs, engine oil, gearbox oil, angle gear oil, timing belt.
 
1 - 20 of 55 Posts
Top