SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Just bought a '00 V70 2.4t. Making a trip with the family and on our way back my Volvo decided to give us trouble.<p>Drive about 4 hours, stop to get gas, when I start the car, the SRS light comes on. Thought it was odd but went on and about 2 blocks later, it just doesn't have any power and won''t shift past 2nd. It won't idle at all, hits 1k then drops back to 200. Bounces like this a few times and finally dies. Won't go more than a few feet. No other lights or warnings when its trying to idle.<p>Any ideas where to start? Had to have it towed to a German/Japenese shop in town.......no Volvo mechanics anywhere. Just want to have an idea if they start coming back with guesses tomorrow.<p>thanks.....stuck in New Mexico
 

·
Registered
Joined
·
63,543 Posts
Re: Stuck in the middle of a road trip! (crash813)

Either the ETM (throttle body) gone bad or a dead battery (not charging), due to either a bad alternator or a <B>bad "B" battery cable</B> (more common).<br>Have the charging system completely checked, start with that, if OK, then it's most likely the <B>ETM</B> (must be done at a Volvo dealer) and maybe still in warranty (10 years from in date of service or 200K miles.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
thanks...... alt was changed about a year ago by PO, was thinking the B cable since its been sounding a little weak when starting....just bad luck I guess...that it couldn't wait til next week
 

·
Registered
Joined
·
63,543 Posts
Re: (crash813)

Charge the battery.<br>If the battery tests out OK and it starts and runs well, that probably is your problem.<br>If it still doesn't, then you have to look at the throttle body
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
If its the B cable, will just charging the battery let it run for awhile? Maybe as long as I don't turn the car off?
 

·
Registered
Joined
·
63,543 Posts
Re: (crash813)

No<br>It will run for a short while depending on the battery<br><B>The more you run it, the worse it will get</B><br> <B>(If it's the B cable</B>), IT'S NOT CHARGING properly and the more you run it with the AC and all the electrical on, the faster it will stop again, (as I said IF)<br>You can tell, open the fuse box under the hood, the cable attaches to it on the RF of the fusebox. <br>It should be a bright copper, (past the rubber) if it's dark and burned, that's not good!
 
1 - 6 of 6 Posts
Top