SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hello all

I have a 2015.5 v60 Polestar...original owner. I have been to my dealer 4 times in last two years for recurrent loud "clunking"noise when car warm and with slow speed turning...seems to be driving fine.

They have changed the left shock and also the strut mounts (twice) and strut bearings once...last done approx 10 000 kms ago in july 2018 under warranty. Presently at 85 000 kms. New brakes/rotors recently.

The Warranty is now expired and noise starting again. I called dealer and they want $150 per hour to troubleshoot and then can't be sure that I wont have to pay for repairs even if same issue. I was a little surprised as I bought the car and have had all my service done at this dealer.

Just wondering if anyone else having similar issues with their front suspension and if how the dealer is handling this seems appropriate.

thx for your advice
 

·
Registered
Joined
·
706 Posts
The strut bearings are basically junk on this car, sorry. I'm on my second set in 28K. The bearing cost $36 a piece, but my local shop charges me $500 to change them. Peter in San Diego is researching Kmax bearings, we'll see.
 

·
Registered
Joined
·
14 Posts
2018 v60 P* , just had my first service done. 16,500km I’ve noticed clicking noise at the right front only when do a full lock of the steering. Told the dealer they basically told me they put some grease on the joint and ask me to monitor it. If I hear the sound again, I would have to go back to the dealer.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
370 Posts
As was said, the mounts on these cars are junk (made by Ford... bleh). My car is at about 21,000 now and I get a creaking sound when turning the wheel when stopped or at low speeds. Seems that the bearing is probably worn or binding or just prematurely failing because... Ford junk. :( Just a guess but I'm thinking the Ohlin struts may be a little bit too much for the OEM mounts. The mounts probably should have been upgraded to match the higher quality struts.

Hopefully the Kmax bearings can be proven as a quality substitution. I really don't want to hit the dealer up for replacement of these just to have them fail again in 20,000 miles. The big thing is getting the car aligned again after the mounts are replaced... and that just gets old.
 

·
Registered
Joined
·
105 Posts
I thought I read somewhere that the upgraded xc90 mounts fit and are better? I am also getting clunking (thought it might be CV joints). Sounds like someone is cracking knuckles with mine. I am at 93k miles and original bearing and struts I think.
 

·
Registered
Joined
·
370 Posts
I thought I read somewhere that the upgraded xc90 mounts fit and are better? I am also getting clunking (thought it might be CV joints). Sounds like someone is cracking knuckles with mine. I am at 93k miles and original bearing and struts I think.
I'd love to know more about the compatibility of XC90 mounts. My assumption is that that would be more robust being that the 90 probably weighs a healthy 400lbs more than either the S60 or V60. The noise you describe is similar to what I get when turning the wheel while stationary. The dealer would cover replacement under the CPO but I don't want to run down that rabbit hole if they will fail again. :/
 
1 - 8 of 8 Posts
Top