SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 · (Edited)
Looking for some help here I've searched around a bit but no one is experiencing this with "new" parts.
I've been chasing a clunk in the front end of my 04 R. In the process of doing this I have replace the upper strut bearing and the spring seat. Bearing is a xc90 replacement. Spring seat is a IPD HD seat. Now the clunk is another story I'll get to in a minute. But now after swapping out the bearings last I'm getting a creak from the rf at the bearing at the outer limits of turning. In the center it's quiet. It was tight going together and it seams that it'd creaking due to the axle gained in the strut not the spinning of the strut. Has anyone ever had this with new parts and did it work it's way out of it?

onto the clunk/pop on the rf also. It does it when the strut becomes unloaded in between compression and rebound when you hit a bump. Everything appears tight ball joints tie rods etc. And everying at the top is new. Also side note I did have a bad ball joint and one mout was bad. With replacing them the clunk has become more prominent. Any help is greatly appreciated. Thanks.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
2,045 Posts
Was the ball joint replaced on that side? The only real way to check ball joint play is to lift the front of the car only about 1in off the ground, suspension unloaded then place a pry bar under the tire and move it up and down and see if there is any play in the ball joint. These ball joints can be bad even if they appear good.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #6 · (Edited)
The creak is definetly coming from the top of the strut. The bad ball joint was on the opposite side. I have unloaded the spindle and checked the ball joint in the traditional way that's how i found the bad one.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #7 ·
I think I'm going to go home and tear the rf apart again I'm starting to be sceptical of the the strut itself.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
2,045 Posts
Wow that thing has alot of play. Either have a bad part or you put it together wrong.

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #11 ·
I wondering if I have a bent strut shaft. I'm about to pull it apart I'll upland pics after its out

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
73 Posts
It sounds to me like you have a strut bearing problem or something was not assembled correctly. When the strut/spring/seat is assembled correctly, they essentially become one fixed unit as far as rotation is concerned. the entire strut/spring assembly rotates by way of the strut bearing. The strut shaft does not rotate. The spring seat fits into the strut bearing which bolts to the strut tower That is where the rotation occurs. From your video, it almost sounds like rubber squeaking.
 

·
Registered
Joined
·
8,055 Posts
Also check the LCA bushings, the way that upper strut mount is deflecting makes it appear there is a lot of movement that there shouldn't be at the lower end of the strut.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #16 ·
I believe it's a defective mount the noise is coming from the bottom of the bearing rubbing on the top of the spring seat.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
8,055 Posts

·
Registered
Joined
·
73 Posts
If I were you, I would replace that dust boot and bump stop. It does not cost that much while you have it apart. Although that is not contributing to your noise problem.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #19 ·
The inside of the bearing actually pushed up into the plate allowing the spring seat to rub on the bottom of the plate. Hard to see in the picture.


Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #20 ·
The x nut as I'll call it on top of the spring seat is tight but I'm going to take it all apart to check the strut shaft.

Sent from my SM-G900V using Tapatalk
 
1 - 20 of 30 Posts
Top