SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Hello,

new guy here :) I would be really gratefull if you could give any suggestions about the problem. My 2007 S80 2.5T makes a strange high rattling/whining sound:


It can be heard all the time after start when the engine had cooled down and was not working for at least 5 minutes. As engine warms up it gradually disappears, but is is directly linked to the acceleration pedal and reappears firs at over 1200 rpm. later over 1300 rpm and step by step disappears at all.

Also, I have noticed that when starting the car after night, for first 1-2 seconds a small amount of exhaust smoke appears in the engine compartment and it comes from somewhere approximately between the driver and front passenger seat.

Any ideas what could be causing this sound?

many thanks!
 

·
Registered
Joined
·
461 Posts
Well, I'm viewing because I'm also interested, but I'll throw in my 2 cents. At first it sounds like an exhaust leak, then later on it sounds like something else, maybe a belt or pulley. I had a similar (not exactly the same) sound on my '03 XC70 (with the 2.5T engine, same as yours) after the dealer installed a used 90K mile engine following a mechanic screw up to engine #1. I took it back 3 times to the dealer for this sound and they kept saying it was nothing to worry about. One day about a year later we found out what it was. A tensioner on the serpentine belt broke causing the serp belt to snag the timing belt and destroy engine #2. So, if I was you, I would have an expert look at it.
 

·
Registered
Joined
·
461 Posts
Let me also note that most of the DIY guys frequent the s40/v50 and s60 (up to 2010) parts of the forum, but since the same 2.5T engine is used in those cars as well you might want to add a post referencing this thread to get some more eyeballs. And also let me welcome you to Swedespeed and wish you luck!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Well, I'm viewing because I'm also interested, but I'll throw in my 2 cents. At first it sounds like an exhaust leak, then later on it sounds like something else, maybe a belt or pulley. I had a similar (not exactly the same) sound on my '03 XC70 (with the 2.5T engine, same as yours) after the dealer installed a used 90K mile engine following a mechanic screw up to engine #1. I took it back 3 times to the dealer for this sound and they kept saying it was nothing to worry about. One day about a year later we found out what it was. A tensioner on the serpentine belt broke causing the serp belt to snag the timing belt and destroy engine #2. So, if I was you, I would have an expert look at it.


Northeast, thank you very much for your insights. Only one question - what causes it to make such sound only when the engine is cold? I am somewhat thinking that it should be related to lack of lubrication.
 

·
Registered
Joined
·
2,147 Posts
Northeast, thank you very much for your insights. Only one question - what causes it to make such sound only when the engine is cold? I am somewhat thinking that it should be related to lack of lubrication.
I had similar symptoms related to a roller or tensioner on my 944S2. very noisy when cold then it quieted down. Don't have an explanation. Sorry.
 

·
Registered
Joined
·
461 Posts
Pretty much exhausted my automotive knowledge already, but I see you got some more responses in the general forum so maybe they will help. After my experience, I always err on the side of caution with similar noises.
 
1 - 8 of 8 Posts
Top