SwedeSpeed - Volvo Performance Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello all!

So I drive a 04 V70 AWD and have been having some strange issues with it. Every once in a while, after shutting off the car, it will not lock with the fob/key/lock button inside. I usually go back to the car and attempt to start it, and when I do, things seem OK when the key turns to position 2, but once the car starts, everything goes dead but the motor is still running. No gauges, radio, climate control, wipers, blinkers, etc. The only method that we have found to fix this is to disconnect/reconnect the battery. The first time after this happened, the keyfob keys no longer work to start the car, with a "Start prevented, try again" message appearing on the info panel, only the valet key works. Second, after reconnecting the battery, a SRS warning appears every time. After talking to a local mechanic, a Volvo dealer, and an auto repair shop (Kansas City Autosport), they do not see anything wrong and have no idea as to what might be causing these electronics failures. Has anyone else experienced this before?

Thanks,

Nathan
 

·
Registered
Joined
·
5,311 Posts

·
Registered
Joined
·
7,612 Posts
Also if the battery is old, it can cause those problems even while having enough juice to start the car. These cars are VERY sensitive to voltage drops. Do you know how old the battery is? If there's any doubt replace it.

3 years ago I was having intermittent dash blackouts, which everyone said would be a faulty DIM. Replaced the battery with a good solid one and no problems since.
 

·
Registered
Joined
·
77 Posts
....
No gauges, radio, climate control, wipers, blinkers, etc.
...
The only method that we have found to fix this is to disconnect/reconnect the battery. The first time after this happened, the keyfob keys no longer work to start the car, with a "Start prevented, try again" message appearing on the info panel,
...
You have issues with low speed CAN bus and possibly with high speed one. Plus issue with reading of the transponder.
Technicians have not found any issues that is very strange. Because in this case there should be error codes stored 100%.

Anyway described symptoms says that looks like it is bad CEM.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Also if the battery is old, it can cause those problems even while having enough juice to start the car. These cars are VERY sensitive to voltage drops. Do you know how old the battery is? If there's any doubt replace it.

3 years ago I was having intermittent dash blackouts, which everyone said would be a faulty DIM. Replaced the battery with a good solid one and no problems since.
The battery is about 3 years old, so I might try that first since it is the least expensive solution.

Could be a CEM issue, they are known to over heat. You can DIY a heat sink onto it and it may resolve your issue. I'd install the heat sink if is there isn't one installed already.

http://www.volvoxc.com/forums/showthread.php?27249-I-added-a-heatsink-to-my-2004-CEM-CPU

The DIM is also known to be faulty and may need to be sent out for rebuilding.
Not too keen at this point to hacking the thing apart and applying a DIY fix but thank you for the info!

You have issues with low speed CAN bus and possibly with high speed one. Plus issue with reading of the transponder.
Technicians have not found any issues that is very strange. Because in this case there should be error codes stored 100%.

Anyway described symptoms says that looks like it is bad CEM.
If the battery does not work, then I'll take it back and have them pull the codes. With the SRS Airbag Warning Urgent, since that happens whenever the battery is reconnected, will they still deploy in a crash or is this something that should be reset by volvo?

Thanks all!

Nathan
 

·
Registered
Joined
·
5,311 Posts
Not too keen at this point to hacking the thing apart and applying a DIY fix but thank you for the info!
FYI: This is pretty much the same fix that is applied to the CEM when it is sent out for "rebuilding". So if you can handle the DIY you can save yourself time and money.
 

·
Registered
Joined
·
77 Posts
With the SRS Airbag Warning Urgent, since that happens whenever the battery is reconnected, will they still deploy in a crash or is this something that should be reset by volvo?
This warning shows that SRS module has some error codes stored. They can be cleared only by scanner that is able to do that.
 

·
Registered
04 XC70
Joined
·
117 Posts

·
Registered
Joined
·
5,311 Posts

·
Registered
Joined
·
1,119 Posts
I know this is a very old thread, but I just looked at a 2004 XC70 for sale, and it pulled these exact codes. No gauge cluster functionality after about 2 seconds, except warning lights seem to work.

I'm debating if I want to buy it for a project car. It's silver with the blue trim. Interior is actually very good for having 234k miles on it.

Owner says there's a delay in throttle response, and turn signals aren't working (could be a switch).

Did anyone find what was causing this code string?
 

·
Registered
Joined
·
1,119 Posts
I skipped this one, and bought a 2005 S80 2.5T AWD with about 140k on it. I'll be creating a new post in that section.
 
1 - 13 of 13 Posts
Top