SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I get a strange rapid clicking sound when I use my clutch, and can't tell what it is! Help! <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <br>If you imagine the rapid clicking sound of a ratchet being turned, that's what it sounds like. It seems to happen with engine movement. If i accelerate it happens, and if i slow down using the gears instead of brakes it does it - in both cases it is when the engine moves on its mounts. I have checked the bottom mounts, abd they're fine. i replaced the top mount (on the cross bar) too. The drive shafts are also good. the only thing I found that I thought strange was that i could move the cross bar forward and backward by hand quite easily (although this does not make the sound). Should it move like this, or be firm / stiff? I have seen an identicle car making the exact same noise when it drove past me.<br>The car is an S60 2.0t SE, in the UK.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
Sorry, I forgot to mention that the noise only happens momentarily, only when the engine rocks, then it stops.
 

·
Registered
Joined
·
181 Posts
Re: (Austin)

the infamous P2 chassis "click", "pop", etc. Just got a new car and after 3000 kms it started. Allegedly fixable (temporarily) with loctite.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Re: (PeterM)

Oh cool, cheers.<br>One thing though............ where do I put the loctite?!?!
 
1 - 5 of 5 Posts
Top